If a system wide search is "deleted" (_hidden set) it cannot be restored normally

RESOLVED DUPLICATE of bug 353056

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 353056
6 years ago
5 years ago

People

(Reporter: nemo, Unassigned)

Tracking

16 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
In brief, I deleted DuckDuckGo (installed in /usr/lib/firefox/distribution/searchplugins/locale/en-US/duckduckgo.xml) by Ubuntu, then discovered I couldn't add it back by going to the website.
In addition, another search on the website with the same ShortName (but different other values) appeared for Add, but when selected, did nothing.

To test, I made a new profile, running against existing Firefox, deleted DuckDuckGo, then went to http://duckduckgo.com - there was no search option to add DuckDuckGo.  In my profile, _hidden: "true" was set, which is presumably how Firefox deals with system-wide searches.  It should have set it to unhide, and allowed me to see the Add option when I went to the website.

If I tested in a separate firefox install, without the system default, I can add/remove just fine.

If I go to http://duckduckgo.com/html after "hiding" the system DuckDuckGo there is an Add option, but it does nothing.

Now as to *how* this happened, I relate it below 'cause it probably happened to others too.

1) I discover DDG, decide it is awesomeness, and add it using the OpenSearch link on http://duckduckgo.com
2) I then go to irc://irc.freenode.net/duckduckgo and tell them.  "You guys are awesome, but if one is using your search with NoScript, one has to click a link after searching to run the actual search, which is annoying"
    I'm told that the fix for this is to go to Manage Search Engines, delete the non-HTML one, then add back from http://duckduckgo.com/html
    "Hmph. That's annoying sez I, you guys should make this more seamless, maybe by swapping out the search URL on frontpage if JS is detected"  Nonetheless, I grumpily apply the fix.
3) I use search happily for a while, then Ubuntu deploys the system-wide search plugin
4) All of a sudden I discover I'm having to click on a link to search.  Annoyed, I try deleting the search, then adding it back again from http://duckduckgo.com/html -  and nothing happens.  The Add link is there, but it refuses to add.  I give up and use my ddg search binding in the URL bar, or just using google.
5) Aftermath... I check http://duckduckgo.com and it now works seamlessly with NoScript - I'm guessing maybe (3) caused a lot of annoyed users, prompting a quick fix to seamlessly redirect such searches to the /html page.  However, due to the Firefox broken behaviour and the overlapping short names, the only fix to get search back was either to make an opensearch XML with a different shortname, or to (presumably, haven't tested) delete the _hidden reference in the search.json in the profile to allow the system DDG to appear again.
(Reporter)

Comment 1

6 years ago
Oh. BTW, for anyone else who ran into this problem and doesn't want to have to manually edit their profile to fix, here's a link to a DuckDuckGoose HTML version with a fixed shortname.  Just hit the site, and choose Add
http://m8y.org/tmp/testcase278.xhtml
OS: Other → All
Hardware: Other → All
Version: Trunk → 16 Branch
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353056
You need to log in before you can comment on or make changes to this bug.