Early cleanup of message listeners in ActivityProxy.js

RESOLVED FIXED in Firefox 18

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: fabrice, Assigned: fabrice)

Tracking

Other Branch
mozilla19
All
Gonk (Firefox OS)
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking-basecamp:-, firefox18 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 672528 [details] [diff] [review]
patch

While debugging bug 802108 I noticed that the ActivityProxy.js component doesn't get a chance to clean up its message listeners because we currently trigger that when the page goes away which does not happen often for some apps like the homescreen.

Since a DOMRequest can only fire success or error once, this patch cleans up the message listeners as soon as possible.
Attachment #672528 - Flags: review?(anygregor)
(Assignee)

Updated

6 years ago
Assignee: nobody → fabrice
(Assignee)

Updated

6 years ago
blocking-basecamp: --- → ?
Attachment #672528 - Flags: review?(anygregor) → review+
We discussed during triage that Fabrice would ask for aurora approval but we won't block on this.
blocking-basecamp: ? → -
(Assignee)

Comment 2

6 years ago
Comment on attachment 672528 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Increased memory usage and useless IPC traffic
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): None
String or UUID changes made by this patch: None
Attachment #672528 - Flags: approval-mozilla-aurora?

Comment 3

6 years ago
Comment on attachment 672528 [details] [diff] [review]
patch

Pre-approving in support of better memory usage on B2G.
Attachment #672528 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 5

6 years ago
https://hg.mozilla.org/mozilla-central/rev/1167feab3ae5
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
https://hg.mozilla.org/releases/mozilla-aurora/rev/e076a9db9f59
status-firefox18: --- → fixed
Flags: in-testsuite-
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.