Closed Bug 802979 Opened 8 years ago Closed 8 years ago

EncodingUtils should use ASCII-only lower casing

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 801487

People

(Reporter: hsivonen, Unassigned)

References

(Blocks 1 open bug, )

Details

EncodingUtils uses ToLowerCase on an UTF-16 string. To avoid matching İ with i, nsContentUtils::ASCIIToLower should be used instead.
The fix and a test is included a patch attached in bug 801487.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801487
> is included a patch
is included *in* a patch
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.