No preview in FF with hardware acceleration enabled if connected remote via Java VNC [TightVNC Viewer]

REOPENED
Unassigned

Status

()

Core
Graphics
REOPENED
6 years ago
6 years ago

People

(Reporter: Cristian-Petru Pencov, Unassigned)

Tracking

18 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID: 20121017042010

Steps to reproduce:

Connect from any computer to work computer [Windows XP Pro SP3] using TightVNC Viewer Java version. Firefox is already open on host computer.


Actual results:

Firefox does not display anything in window / tabs. I see only blank window frame. If I try to open another instance, doesn't change the situation. I use other browsers [Safari, Chrome] and do not have this problem.


Expected results:

I should see sites like if I would be at the desktop computer. This doesn't happen if I'm using RDP or VNC Viewer application.

Comment 1

6 years ago
Could you try with the hardware acceleration disabled in FF18 (in advanced options, restart FF).
(Reporter)

Comment 2

6 years ago
(In reply to Loic from comment #1)
> Could you try with the hardware acceleration disabled in FF18 (in advanced
> options, restart FF).

Works. Thank you very much for tip!
I just don't get it, why this setting exist if it cause such more troubles. What is difference between using it or not! I suppose I'm not the only one who encounter problem regarding "Hardware Acceleration".

Regards,
Cristian
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 3

6 years ago
I reopen it because it could be a bug in Firefox HWA implementation.
A few questions:

1) HWA is better with GPU drivers up-to-date. Check about:support > graphics and be sure your drivers are up-to-date. If not, update them, please.

2) Did it use to work normally (with HWA on) with previous versions of Firefox (like FF16, FF15 etc) and TightVNC Viewer?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---

Updated

6 years ago
Component: Untriaged → Graphics
Product: Firefox → Core

Updated

6 years ago
Summary: No preview in FF if connected remote via Java VNC [TightVNC Viewer] → No preview in FF with hardware acceleration enabled if connected remote via Java VNC [TightVNC Viewer]
Bas, do you know if TightVNC Viewer does the same thing as Windows remote desktop viewer?
Flags: needinfo?(bas)
(In reply to Joe Drew (:JOEDREW! \o/) from comment #4)
> Bas, do you know if TightVNC Viewer does the same thing as Windows remote
> desktop viewer?

I'm pretty sure it does something different. I wouldn't be surprised if this is a bug in TightVNC rather than Firefox. But it's hard to say for sure.
Flags: needinfo?(bas)
You need to log in before you can comment on or make changes to this bug.