[Clock] Time picker messes up when (1) set alarm (2) kill app (3) alarm fires

VERIFIED FIXED

Status

Firefox OS
Gaia
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Gene Lian (I already quit Mozilla), Assigned: iliu@mozilla.com, ianliu.moz@gmail.com)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
## STR:
  1. Launch the clock app.
  2. Set an alarm to fire in about 1 min.
  3. Long-push the homescreen button to kill the clock app.
  4. Wait on the alarm firing.
  5. Open the clock app.
  6. Reset the previous alarm at #2 or set another new alarm.

## Expected:
  A normal time picker should be displayed.

## Actual:
  The time picker messes up.
(Reporter)

Updated

5 years ago
blocking-basecamp: --- → ?

Comment 1

5 years ago
Unagi build 10/17/12

Time picker second time contains no actual numbers.
I believe that this is a dup of bug 796831 which is marked a dup of bug 799644.

clee, I would like to have bug 799644 set as a higher priority as it happens all over the place in b2g.
blocking-basecamp: ? → +
Priority: -- → P2
(Assignee)

Updated

5 years ago
Assignee: nobody → iliu
Ian said this should be a bug in Clock regarding init calling sequence.
This somewhat still occurs.  I had the time picker show numbers, but when I scrolled the numbers scrolled off the screen until it became blank.

Otoro phone, build 2012-10-23
Taken from default.xml in b2g-distro: 
* "platform_build" revision= db539a3bd139c93c09b0cd1c3f9396b74d68717c
* "gaia" revision= 0b8ec9b8c16429dc35453dbb7b9342fab3dd18fb 
* "releases-mozilla-aurora" revision= f58edfde05cb708f8a2c440d338f2e429aaf372b
* "gonk-misc" revision= db0c751715f4696515735eb1e0dc5df7a40eb81d
Can't seem to reproduce this without killing the clock app.  This particular bug is only in the clock app as far as I can tell...

Updated

5 years ago
Priority: P2 → --
P3, qawanted: Can we get a screenshot, and an assessment of whether this is visual disruption only, or actual functional bustage.  If the former, can you renominate so we can re-assess this bug?
Keywords: qawanted
Priority: -- → P3

Comment 7

5 years ago
I can't reproduce this follow the STR
Gene, can you check it again?
(In reply to John Shih from comment #7)
> I can't reproduce this follow the STR
> Gene, can you check it again?
Hi John,

I can reproduce it.
I'll take over it.
Thanks for your check.
Created attachment 676922 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6105

Pointer to Github pull-request
Comment on attachment 676922 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6105

The picker got wrong value of the client height when Clock APP is launching and initial in the background.
It will make the picker messes up with wrong offset height.

We only need to initial the picker when Clock APP really goes into alarm-edit page.
Attachment #676922 - Flags: review?(rlu)
(Assignee)

Updated

5 years ago
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Comment on attachment 676922 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/6105

Looks good to me.
r+
Attachment #676922 - Flags: review?(rlu) → review+
Fixed with https://github.com/mozilla-b2g/gaia/pull/6105.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Verified able to set multiple consecutive alarms with no issues on the time picker.
Status: RESOLVED → VERIFIED
removing QAwanted since rebecca verified the fix for this bug.
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.