Rendering is broken after restoring skew() support

VERIFIED FIXED

Status

()

Core
Layout: View Rendering
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: alindeac, Assigned: dbaron)

Tracking

({regression})

17 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17+ verified, firefox-esr10 unaffected)

Details

(URL)

+++ This bug was initially created as a clone of Bug #747637 +++

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/22bfdebf5cae
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120420 Firefox/14.0a1 ID:20120420030653

Rendering is broken due to Remove skew() transformation function

When verifying this fix on Firefox 17 beta 1, I observed some rendering issues that are not reproducible on Firefox 16 beta 6.

Steps to reproduce:
1. Navigate to:
http://ie.microsoft.com/testdrive/Graphics/hands-on-css3/hands-on_2d-transforms.htm
2. Select skew(θx,θy)of "Append another transform function"dropdown
3. Change degree by slider.

Expected results:
Rendering is fine

Actual results: 
Rendering issues when changing degree by slider (easily reproducible on Ubuntu 12.04 but also on Mac OS X 10.7 and Windows 7). Please see the attachment for more details.
https://bug747637.bugzilla.mozilla.org/attachment.cgi?id=672306
The bug summary seems to have nothing to do with comment 0.  Which one is correct?
status-firefox16: verified → ---
status-firefox17: verified → affected
tracking-firefox16: + → ---
Summary: Restore skew() support → Rendering is broken after restoring skew() support
(Assignee)

Updated

5 years ago
Component: Style System (CSS) → Layout: View Rendering
Keywords: dev-doc-complete

Comment 2

5 years ago
This is not a skew(θx,θy) specific problem. This problem also happens in skew(θy) .

There are two problems.
[1] Garbage is left --- reproduced in Firefox17beta only
[2] Texts disappear  --- reproduced in Firefox17beta, Aurora18.0a2 and Nightly19.0a1.

Steps to reproduce(Example):
1. Navigate to:
http://ie.microsoft.com/testdrive/Graphics/hands-on-css3/hands-on_2d-transforms.htm
2. Select skew(θy) of "Append another transform function" dropdown
3. Change degree by slider.

Actual results:
  [1]Garbage is left.
  [2]And After repeat step3 several times, Texts in the skewed element are not displayed after all.
  Screen capture: http://youtu.be/3W4LYIstLmI at 00:57

Expected results:
  Rendering should be performed properly.

Comment 3

5 years ago
Correction of comment #2
>[2] Texts disappear  --- reproduced in Firefox17beta, Aurora18.0a2 and Nightly19.0a1.
[2] Texts disappear  --- reproduced in Firefox17beta, Aurora18.0a2 and Nightly19.0a1 and Firefox16.0.1 as well
I went and tried out the STR and have questions: How widespread would this issue be for average users on popular sites? Is there anything specific to this particular demo?

Comment 5

5 years ago
I do not have experienced other than this demonstration.
(In reply to Alice0775 White from comment #2)
> This is not a skew(θx,θy) specific problem. This problem also happens in
> skew(θy) .
> 
> There are two problems.
> [1] Garbage is left --- reproduced in Firefox17beta only
> [2] Texts disappear  --- reproduced in Firefox17beta, Aurora18.0a2 and
> Nightly19.0a1.
> 
I can't reproduce the second problem. The text does not disappear for me on none of the Firefox versions that you mentioned. Did you change some other settings?
The regression range for the first problem mentioned in Comment 2:

Last good nightly: 2012-08-13
First bad nightly: 2012-08-14

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f89feda9d997&tochange=22288130fea2

Comment 8

5 years ago
(In reply to Mihaela Velimiroviciu [QA] from comment #6)
> (In reply to Alice0775 White from comment #2)
> > This is not a skew(θx,θy) specific problem. This problem also happens in
> > skew(θy) .
> > 
> > There are two problems.
> > [1] Garbage is left --- reproduced in Firefox17beta only
> > [2] Texts disappear  --- reproduced in Firefox17beta, Aurora18.0a2 and
> > Nightly19.0a1.
> > 
> I can't reproduce the second problem. The text does not disappear for me on
> none of the Firefox versions that you mentioned. Did you change some other
> settings?

I ran with clean profile.So nothing changed, but I ran Firefox in "Windows Classic" not "Aero".
Graphics      
  Adapter Description : ATI Radeon HD 4300/4500 Series
  Adapter Drivers : aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  Adapter RAM : 512
  ClearType Parameters : Gamma: 2200 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 50 
  Device ID : 0x954f
  Direct2D Enabled : true
  DirectWrite Enabled : true (6.1.7601.17789)
  Driver Date : 7-3-2012
  Driver Version : 8.970.100.3000
  GPU #2 Active : false
  GPU Accelerated Windows : 1/1 Direct3D 10
  Vendor ID : 0x1002
  WebGL Renderer : no information
  AzureCanvasBackend : direct2d
  AzureContentBackend : direct2d
  AzureFallbackCanvasBackend : cairo
David is this yours or Aryeh's maybe?  Possible fallout from bug 747637 not backing out exactly cleanly?  I notice some user relief in that bug that skew() was restored so maybe you'll have a better idea of how serious this regression is for our user base and also have some ideas on what to do here.
Assignee: nobody → dbaron
That looks like the same regression range as bug 804323. Also transforms related.

Comment 11

5 years ago
Appears to be fixed by 804323.
Bug 804323 did a backout of bug 691591 on beta, and will land a fix to aurora (18) to fix this.
status-firefox17: affected → fixed
Would be great to have QA verify before we build Beta 5 (Tues Nov 6)
Keywords: qawanted, verifyme
(In reply to Lukas Blakk [:lsblakk] from comment #13)
> Would be great to have QA verify before we build Beta 5 (Tues Nov 6)

What specifically needs verification? I'm assuming we need to verify that bug 804323 is fixed for 17.0b4 and also that comment 2 does not reproduce in the same build. Please indicate if anything is missing or incorrect.

PS. It would be great to get this information up front in the future.

Comment 15

5 years ago
(In reply to Alice0775 White from comment #2)
> There are two problems.
> [1] Garbage is left --- reproduced in Firefox17beta only
> [2] Texts disappear  --- reproduced in Firefox17beta, Aurora18.0a2 and
> Nightly19.0a1.

I just tried the STR using beta 4.

Problem [1] now seems to be fixed.
Problem [2] I was unable to reproduce even in previous betas.

Comment 16

5 years ago
I cannot reproduce these Problem [1]and[2] in the following recent builds anymore.

http://hg.mozilla.org/releases/mozilla-beta/rev/486335dcb4a2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0 ID:20121031065642
http://hg.mozilla.org/releases/mozilla-aurora/rev/46a6feeaf9c5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121101042011
http://hg.mozilla.org/mozilla-central/rev/5bd5bb168eb1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/19.0 Firefox/19.0 ID:20121101030705
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
I'm calling this bug verified based on comment 16. Thanks Alice!
Status: RESOLVED → VERIFIED
status-firefox17: fixed → verified
Keywords: qawanted, verifyme
You need to log in before you can comment on or make changes to this bug.