please rack and cable 25 iX nodes for w8 testing

RESOLVED FIXED

Status

Infrastructure & Operations
DCOps
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: arr, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
25 iX nodes should be arriving from iX Systems to scl3 in the next few weeks (not to be confused with the 20 arriving in scl1).  These are meant to be be used for w8 testing and should be connected to vlan 240 (primary nic) and VLAN 216 (management/oob/ipmi interface).  

Hosts have been entered into dns and basic info has been entered into inventory.  Please update inventory with asset, serial, rack, switch, etc info when the machines are put in place.

If you could please also provide us with a spreadsheet of MACs for the oob and the primary nic, that would be fabulous.  We can then automate all of the DHCP entries for inventory.

Hostnames for these are:

t-w864-ix-001.wintest.scl3.mozilla.com
...
t-w864-ix-100.wintest.scl3.mozilla.com

Oob hostnames are:

t-w864-ix-001-mgmt.inband.scl3.mozilla.com
...
t-w864-ix-100-mgmt.inband.scl3.mozilla.com

Updated

5 years ago
colo-trip: --- → scl3

Updated

5 years ago
Depends on: 803224
:arr, to confirm, you won't need per-outlet switching PDUs for these?
(Reporter)

Comment 2

5 years ago
Correct per-outlet switching PDUs not required.
Depends on: 803354
Doing "last call" for concerns in email - will update in a few days with final decision.
(Reporter)

Comment 4

5 years ago
hwine: I'm not sure what concerns you're referring to?
arr: concerns from releng, to be summarized in a final-request-from-releng here
argh - ignore comment #3 & comment #5 - wrong bug. Sorry
Depends on: 819957
I updated the PO bug but wanted to update here as well.  We expect delivery of these systems on 1/9 or 1/10.
Delivery of the iX nodes is Friday, February 8th
Depends on: 837284

Updated

5 years ago
Depends on: 838381
(Reporter)

Comment 9

5 years ago
Slight change in allocation.  We're going to set aside two of these one hundred nodes (half a chassis) for linux prototyping.  Please configure them as follows (DNS and bare inventory entries already exist):


t-w864-ix-001.wintest.releng.scl3.mozilla.com (VLAN 240)
...
t-w864-ix-098.wintest.releng.scl3.mozilla.com (VLAN 240)

talos-linux32-ix-001.test.releng.scl3.mozilla.com (VLAN 256)
talos-linux64-ix-001.test.releng.scl3.mozilla.com (VLAN 256)

Oob hostnames are:

t-w864-ix-001-mgmt.inband.releng.scl3.mozilla.com (VLAN 216)
...
t-w864-ix-098-mgmt.inband.releng.scl3.mozilla.com (VLAN 216)

talos-linux32-ix-001-mgmt.inband.releng.scl3.mozilla.com (VLAN 216)
talos-linux64-ix-001-mgmt.inband.releng.scl3.mozilla.com (VLAN 216)
(Reporter)

Updated

5 years ago
Blocks: 839276
(Reporter)

Updated

5 years ago
Blocks: 839278
(Reporter)

Comment 10

5 years ago
To be clear, we'll need the same info that we needed for the foopies we put in scl1 so we can get all of the necessary info into inventory.  If you guys want to get me csvs or set up a google doc, that will work (or you can input the info yourselves based on the scripts I gave to van a while back).  Let me know what works.

Comment 11

5 years ago
Received 24 of 25 systems. We can start unboxing and racking them Monday.

Van
(Reporter)

Comment 12

5 years ago
As I mentioned to Van on Friday, it helps us if we can get even a handful of systems up and running before they're all fully racked and cabled.  If you could make the first chassis include the two linux machines and two w8 machines, that would be optimal.

Comment 13

5 years ago
We have set up 2 linux and 2 w8 machines first for you.

[vle@admin1a.private.scl3 ~]$ fping t-w864-ix-001-mgmt.inband.releng.scl3.mozilla.com
t-w864-ix-001-mgmt.inband.releng.scl3.mozilla.com is alive
[vle@admin1a.private.scl3 ~]$ fping t-w864-ix-002-mgmt.inband.releng.scl3.mozilla.com
t-w864-ix-002-mgmt.inband.releng.scl3.mozilla.com is alive
[vle@admin1a.private.scl3 ~]$ fping talos-linux32-ix-001-mgmt.inband.releng.scl3.mozilla.com
talos-linux32-ix-001-mgmt.inband.releng.scl3.mozilla.com is alive
[vle@admin1a.private.scl3 ~]$ fping talos-linux64-ix-001-mgmt.inband.releng.scl3.mozilla.com
talos-linux64-ix-001-mgmt.inband.releng.scl3.mozilla.com is alive
While you're setting these up, do you mind ensuring that their boot order is disk-first?  It looks like at least talos-linux32-ix-001 is booting PXE first.

Updated

5 years ago
Depends on: 840363
(Reporter)

Comment 15

5 years ago
Full inventory added for all but the last chassis (still pending delivery).

Comment 16

5 years ago
All hosts' mgmt interface are pingable now.
(Reporter)

Updated

5 years ago
Depends on: 780025
(Reporter)

Comment 17

5 years ago
It does not appear that these new machines are picking up dhcp on the primary interface (nic0).  Are they in the correct vlan (240?).
(Reporter)

Comment 18

5 years ago
Also, FYI, the spreadsheet I was given had the wrong domains for the switches.  They're in console.scl3.mozilla.net, not scl3.mozilla.net.

Comment 19

5 years ago
changed VLAN friendly name and tagged ports. :arr confirmed she is seeing the host PXE boot now.

+   interface-range win8 {
+       member-range ge-0/0/0 to ge-0/0/36;
+       member-range ge-1/0/0 to ge-1/0/36;
+       unit 0 {
+           family ethernet-switching {
+               port-mode access;
+           }
+       }
+   }
[edit vlans]
+   releng-wintest {
+       vlan-id 240;
+   }
-   wintest {
-       vlan-id 240;
-   }

Comment 20

5 years ago
The last chassis has been received and installed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 21

5 years ago
The last 4 nodes have been added to inventory.
(Reporter)

Comment 22

5 years ago
I'm unable to ping the OOB interface of the last 4 machines.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 23

5 years ago
They're up now.

[vle@admin1a.private.scl3 ~]$ fping t-w864-ix-09{5..8}-mgmt.inband.releng.scl3.mozilla.com.
t-w864-ix-095-mgmt.inband.releng.scl3.mozilla.com. is alive
t-w864-ix-096-mgmt.inband.releng.scl3.mozilla.com. is alive
t-w864-ix-097-mgmt.inband.releng.scl3.mozilla.com. is alive
t-w864-ix-098-mgmt.inband.releng.scl3.mozilla.com. is alive
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Assignee: server-ops → server-ops-dcops
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.