URL drop-down list does not scroll on click-hold-and-drag

RESOLVED EXPIRED

Status

SeaMonkey
Location Bar
--
enhancement
RESOLVED EXPIRED
17 years ago
8 years ago

People

(Reporter: Casey Perkins, Unassigned)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Reproducible: Always
Steps to reproduce:
1) Click the drop-down arrow in the URL bar to open the list of typed-in URLs.
2) Hover the mouse down just past the last visible item.
3) Repeat this process, dragging in step two instead of hovering.

Expected result: The URL list scrolls to show the previously hidden entries.
Actual result: Only one more item displays, and that item had been partially
visible before. Items which were not partially visible before will not be
displayed (scrolled into view).
It's debatable whether the hovering part of this should be implemented. I think
so, but it doesn't work on N4 or IE. But the dragging part works on both of
those browsers and should be considered standard behavior.

Comment 1

17 years ago
the fact that it scrolls at all is a bug in the outliner.. it should not be
scrolling on hover at all.
(Reporter)

Comment 2

17 years ago
Even so, it's definitely a bug that it doesn't scroll on drag. 

Comment 3

17 years ago
it should only scroll when you use the arrow keys or the scrollbar, which seem
to work, and you can't drag & drop INTO the dropdown, so I don't see how this is
a bug, sorry.. I'm marking INVALID, nothing personal :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

17 years ago
This is a bug, if you count behavior that's standard in IE and Netscape 4 as
correct behavior. I'm not referring to the hover part, but the **drag** part.
Open up Netscape 4 or IE, and, assuming you have used either enough to have a
full URL drop down list, you will see that if you click and hold down in the URL
list and drag down, that the other items will scroll into view.
True or not?

Comment 5

17 years ago
Ah! I see what you are talking about ..
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Summary: URL drop-down list only scrolls one item on drag or hover → URL drop-down list does not scroll on click-hold-and-drag

Comment 6

17 years ago
however, it's pretty minor, so I'm futuring..
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → Future

Comment 7

17 years ago
I found this as well, in 2001060604. The buggy part seems that it's inconsistent
with where/when it recognizes a click-drag. If I drag down about 20 or so pixels
(on a 1024x768 display) then it takes effect and scrolls normally. Now,
scrolling back up, when grabbing the bottom of the bar is a bit wonky, as it
jumps up as though I clicked in a blank area of the bar to speed scroll. Odd.

Classic Skin if that matters.

Comment 8

17 years ago
reassign url bar bugs to new owner..
Assignee: alecf → blakeross
Status: ASSIGNED → NEW
Target Milestone: Future → ---

Comment 9

17 years ago
Joe was dying to have these bugs. Who am I to say no?
Assignee: blakeross → hewitt

Updated

17 years ago
Severity: normal → enhancement
Status: NEW → ASSIGNED
Priority: P3 → P4
Target Milestone: --- → Future

Comment 10

16 years ago
Just my 2 cents...
It would be extremely convenient if I could use the wheel on my mouse to scroll
through the list of previously typed URLs.  I can do this in IE, and I find it
quite useful.  This may or may not be a bug, but it is certainly a feature
having to do with the convenience of the drop-down list.

Not a big deal, just a suggestion.
Erik

Comment 11

16 years ago
I noticed this bug as well, although mine is specific to the Imported IE
Favourites scroll-down.

Is it going to be fixed? It's my only problem with Mozilla thus-far.

Comment 12

16 years ago
This problem is not specific to the URL list.

Drop-downs in a web-page also refuse to scroll on click-to-open+drag.

This is not just an IE / Netscape thing, it's an interface-wide thing. Try the
font drop-down in MS-Word's toolbar, or any dropdown on the Mac.

* Click and hold (on the menu or the drop-down arrow button)
* drag up or down 
* once you reach the end of the list that has appeared, it should begin to scroll

Should I file a new bug for this more general problem?

Comment 13

14 years ago
How is this an enhancement if it used to work and is now broken?  This has been
open for 3+ years and is worse than "minor".
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
Assignee: hewitt → nobody
Status: ASSIGNED → NEW
Priority: P4 → --
QA Contact: claudius → location-bar
Target Milestone: Future → ---

Comment 14

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 15

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 16

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 17

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 19

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 20

9 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 21

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago8 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.