firefox does not realize when there is no internet connection when checking for addon updates

RESOLVED DUPLICATE of bug 801411

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 801411
6 years ago
4 years ago

People

(Reporter: ill, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010234852

Steps to reproduce:

When the checking for addon updates window comes up after you restart firefox after an upgrade, if there is no connection available due to a required authentication that redirects dns inquiries to a login url, firefox does not realize this and continues trying for several minutes, blocking the user from being able to login. Even when you hit cancel, it still does not immediatly cancel and takes a minute before the screen closes.


Actual results:

see above


Expected results:

see above

Comment 1

6 years ago
If you're offline, it's bug 801411. But if you're being redirected to a login url (captive portal), then you're not really offline. I don't think it's filed before, but it should be dependent on bug 562917.

Comment 2

6 years ago
@ill: Same here
I have a college proxy that needs to be logged in first before going online and the Addon window remains still for minutes.
I guess the Network Component of it should first try a ping, before sending any query because the IP is resolved even if i havnt logged in i.e. DNS responds but do not allow us to connect OR maybe the request timeout of it(the addon window) is in extended mode(which should not be).
--- Just Guessing the cause. :)

Updated

6 years ago
Depends on: 562917

Updated

5 years ago
OS: Linux → All
Hardware: x86_64 → All
Version: 16 Branch → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 801411
You need to log in before you can comment on or make changes to this bug.