Detect swapping when profiling

REOPENED
Unassigned

Status

()

REOPENED
6 years ago
6 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I though I was seeing a Gecko hang but turns out I was linking libxul.so and had ~10MB of ram free. We should detect this condition so we can easily weed out swapping performance bug.

What's the best way to know we're swapping and can we quantify it?

Comment 1

6 years ago
This is a very specific case of the other bug that I've filed about detecting when our thread can be scheduled.  I don't think this specific case is worth fixing before that.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 791357
(Reporter)

Comment 3

6 years ago
Actually I've been looking at the API and it doesn't look like bug 791357 will get us there. There API are uncertain at this point. While tagging a profile with available memory is possible.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.