Warnings file not saved if build fails

RESOLVED DUPLICATE of bug 807974

Status

()

Core
mach
RESOLVED DUPLICATE of bug 807974
5 years ago
5 years ago

People

(Reporter: gps, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mentor=gps][lang=python])

(Reporter)

Description

5 years ago
If an exception is raised as part of building with mach, the warnings file is not saved to disk.

We should probably add a try..finally or context manager to ensure the warnings database is always saved, even if the build is aborted prematurely.

To anyone interested in tackling this, the file in mozilla-central is python/mozbuild/mach/commands/build.py. You'll need to ensure that the line:

    warnings_database.save_to_file(warnings_path)

is always called, even if the _run_make command above it throws.
(Reporter)

Comment 1

5 years ago
This was addressed in bug 807974.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 807974
You need to log in before you can comment on or make changes to this bug.