Attempting to add a gmail account to email says "An unknown error occurred"

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: mossop, Unassigned)

Tracking

({b2g-testdriver, unagi})

unspecified
x86_64
Windows 7
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
I tried adding gmail and after a few moments it just says "An unknown error occurred" and gives me an option to do manual setup. I tried that too and it does the same thing.

Updated

6 years ago
blocking-basecamp: --- → ?

Updated

6 years ago
Component: Gaia → Gaia::E-Mail
QA Contact: tchung
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 796586
blocking-basecamp: ? → +
(Reporter)

Comment 2

6 years ago
Bug 796586 is a calendar bug, not an email bug. And I'm pretty sure I'm using the correct username/password.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

6 years ago
Do you have an adb logcat I could look at?
(Reporter)

Comment 4

6 years ago
I'm not going to be able to test this until bug 804321 is solved
I'm seeing the same error trying to add my mozilla email. I will try again and attach an adb logcat.
And of course the next time I try, it works just fine. Sorry!

Comment 7

6 years ago
(In reply to Nick Hurley [:hurley] from comment #6)
> And of course the next time I try, it works just fine. Sorry!

Chances are you're just seeing temporary network troubles. If you do run into this and can get a log, that would still be useful, because we might be able to intelligently recover and make things work anyway.

Comment 8

6 years ago
Dave, can you still reproduce this today?  Minus'ing this for now, and please re-nom if this still happens.  Thanks.
blocking-basecamp: + → ---
(Reporter)

Comment 9

6 years ago
Created attachment 676290 [details]
log

Yes this still happens, attached is the log after entering the account details.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?

Comment 10

6 years ago
The log tells me you are not using @gmail.com or @googlemail.com (since it's trying an MX lookup). What is the domain you're trying with?
(Reporter)

Comment 11

6 years ago
My own domain, oxymoronical.com, which uses google apps

Comment 12

6 years ago
Ok, I think I have a fix for this, but since I don't have access to a Google Apps domain, I can't test it personally. If you like, I can post a patch for you to test out.
(Reporter)

Comment 13

6 years ago
I believe I'm not meant to flash new builds to this dogfooding phone (if I even knew how to build or flash it!)

If you like I can create you a test account in my apps domain for you to test with.

Comment 14

6 years ago
(In reply to Dave Townsend (:Mossop) from comment #13)
> If you like I can create you a test account in my apps domain for you to
> test with.

That'll work. You can email me with the auth details at my bugmail account or my @mozilla.com address, which is my first initial + my last name.

Comment 15

6 years ago
Ok, I got this working.

The GELAM PR is here: <https://github.com/mozilla-b2g/gaia-email-libs-and-more/pull/71>. Once that's done, I'll issue a PR against Gaia proper.

Comment 16

6 years ago
Fixed in PR https://github.com/mozilla-b2g/gaia/pull/6067
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Updated

6 years ago
blocking-basecamp: ? → +
Priority: -- → P1
(Reporter)

Updated

6 years ago
Status: RESOLVED → VERIFIED

Comment 17

6 years ago
I don't get this error anymore but I get now "Invalid username or password".

I have filed bug 809728.

Stable build: 11-06
You need to log in before you can comment on or make changes to this bug.