content/media/test/gizmo.mp4 has wrong duration in manifest, causing GStreamer test failures

RESOLVED FIXED in mozilla19

Status

()

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: cpearce, Assigned: cpearce)

Tracking

Trunk
mozilla19
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

content/media/test/gizmo.mp4 has its duration in manifest.js listed as 5.0s, but it's duration is actually 5.56s. This incorrect duration is causing the GStreamer H.264 test failures, but it won't be the cause of the timeouts when GStreamer is used to play Ogg/WebM, or the shutdown hang after the test run.
(Assignee)

Comment 1

7 years ago
Correct duration of gizmo.mp4 to 5.56s. I got this duration by running the file through ffmpeg.
Attachment #673090 - Flags: review?(chris.double)

Updated

7 years ago
Attachment #673090 - Flags: review?(chris.double) → review+
https://hg.mozilla.org/mozilla-central/rev/11665365c7c0
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla19
You need to log in before you can comment on or make changes to this bug.