crashing in memory usage test

VERIFIED INVALID

Status

Core Graveyard
Embedding: GTK Widget
--
blocker
VERIFIED INVALID
17 years ago
6 years ago

People

(Reporter: tracy, Assigned: blizzard)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
teh gtkEmbed product is crashing in the memory usage test.  The test will load 
pages with the following in the console for each page:

JavaScript error:
 line 0: onDocumentLoad is undefined

some pages (i.e. www.voodooextreme.com) will get this on the console or crash:

JavaScript error:
 line 0: uncaught exception: null

the test runs lists of 46 static URL's 3 times. Sometimes it'll get past teh 
crashing pages with the null error...but it hasn't made it through the entire 
test list yet. So plotable data is not produced. Thus the blocker status.
(Reporter)

Comment 1

17 years ago
i will begin a binary search on the builds to see if I can begin to narrow down 
when this may have happened. somebody holler HALT if it isn't necessary.

Updated

17 years ago
Keywords: crash
(Reporter)

Comment 2

17 years ago
split one... it must be after 4/25
split two... it is since 5/3
(Reporter)

Comment 3

17 years ago
this is from 2001-05-10-08

+++ loading http://jrgm.mcom.com/perf/loadtime5/base/www.voodooextreme.com
JavaScript error: 
 line 0: uncaught exception: [Exception... "Component returned failure code: 0
0004005 (NS_ERROR_FAILURE) [nsIDOMPluginArray.length]"  nsresult: "0x80004005 
S_ERROR_FAILURE)"  location: "JS frame :: http://jrgm.mcom.com/perf/loadtime5/
se/www.voodooextreme.com/res/_js.js?acct=WQ591227HNWN28EN0&m=w116&n=Main+Page 
 <TOP_LEVEL> :: line 10"  data: no]JavaScript error: 
 
line 0: onDocumentLoad is not defined

this is from 2001-05-11-05

loading url http://jrgm.mcom.com/perf/loadtime5/base/www.voodooextreme.com
JavaScript error: 
 line 0: uncaught exception: null

JavaScript error: 
 line 0: onDocumentLoad is not defined

it didn't crash on this pass, but sometimes it does crash at this site or others
that are getting the same uncaught exception: null javascript error.

it seems the problem was caused by something between yesterday morning and this
morning.

note: the onDocumentLoad is not defined has been around since at least 4/25.
(Reporter)

Comment 4

17 years ago
something happened between friday and today, this is working fine now. No 
crashes, no JavaScript errors.  Marking invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Updated

17 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

17 years ago
verified
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.