Closed Bug 803470 Opened 8 years ago Closed 8 years ago

Freeze when visiting Google Data Center via Google StreetView

Categories

(Core :: JavaScript Engine, defect)

18 Branch
x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla19
Tracking Status
firefox18 + verified
firefox19 --- fixed

People

(Reporter: whimboo, Assigned: mjrosenb)

Details

(Keywords: hang, regression, Whiteboard: [ion:p1][qa-])

Attachments

(2 files)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/18.0 Firefox/18.0 ID:20121018042010

Today Firefox froze completely when I was doing a walk through the Google datacenter via Google StreetView.

Steps:
1. Load https://maps.google.com/maps?hl=en&ll=35.898645,-81.548671&spn=0.005945,0.012306&sll=35.900197,-81.547024&layer=c&cid=7373938251588581469&panoid=QJRzrgIKmN4uPQg7lmOGww&cbp=13,119.83,,0,3.72&gl=US&t=m&z=17&cbll=35.898621,-81.548447

2. Enter the building and take the stairs into the second floor

3. Turn right and quickly go forward so you pass the green wall

At this point Firefox freeze and I  had to force kill the application. I will attach a sample made with activity monitor which will hopefully be of help. So far I haven't been able to reproduce it.
Hmm.  This looks like a dup of bug 799282 (via bug 800393), but that claims to be fixed on Aurora...
Keywords: regression
*groan* not again :(
Marty, how hard would it be to introduce a cutoff to range analysis? We've seen a few sporadic cases of it hanging browsers, even after bug 799282 landed. If this is simple, it would be a free stability win until we get better STR.
Flags: needinfo?(mrosenberg)
oh, I have a patch for that lying around.  I'll post it as soon as I can find it.
Flags: needinfo?(mrosenberg)
fixed up the non-posted patch to be more compatible with any future changes.
Attachment #681791 - Flags: review?(dvander)
Comment on attachment 681791 [details] [diff] [review]
/home/mrosenberg/patches/bailOnILoop-r1.patch

Review of attachment 681791 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #681791 - Flags: review?(dvander) → review+
Assignee: general → mrosenberg
Status: NEW → ASSIGNED
landed: https://hg.mozilla.org/integration/mozilla-inbound/rev/4f37c3ad5cda
We may want to not close this bug, since this is just a workaround / a measure to detect when this happens in the future, not an actual fix.
;)
Whiteboard: [ion:p1] → [ion:p1][leave open]
Marking FIXED since range analysis has changed significantly, the workaround will only exist on branch.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 681791 [details] [diff] [review]
/home/mrosenberg/patches/bailOnILoop-r1.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): IonMonkey
User impact if declined: Possible hang on Google street maps
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): Very little, it detects when a small performance analysis pass in IonMonkey might hang and aborts the pass.
String or UUID changes made by this patch:
Attachment #681791 - Flags: approval-mozilla-beta?
Attachment #681791 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
It has been two weeks since the Beta approval without any patch landing.
Whiteboard: [ion:p1][leave open] → [ion:p1]
Target Milestone: --- → mozilla19
Could not reproduce in 2012-10-18 Aurora
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/18.0 Firefox/18.0
Build ID:  20121018042010

But there is no freeze in Latest Aurora
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20121211 Firefox/19.0
Build ID: 20121211042015

and in Firefox 18.0 Beta 3
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID:  20121205060959
(In reply to Virgil Dicu [:virgil] [QA] from comment #14)
> Could not reproduce in 2012-10-18 Aurora

I just want to note that this was a one-time crash for me and I was never able to reproduce. So it might be hard to really verify that.
Marking this [qa-] since this was a one-time crash that was not reproducible, as per comment 15. We won't be able to reliably verify this is fixed.
Whiteboard: [ion:p1] → [ion:p1][qa-]
You need to log in before you can comment on or make changes to this bug.