[lock screen] animated arrows are sometimes visible shortly before unlocking

VERIFIED FIXED

Status

Firefox OS
Gaia
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ttaubert, Assigned: ttaubert)

Tracking

({polish})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
> .touched .lockscreen-arrow,
> #screen:not(.locked) .lockscreen-arrow {
>   display: none;
>   animation: none;
> }

The arrows are hidden while the handle is touched. On mouseup the 'touched' class is removed and a transitionend listener is registered that then unlocks the screen. While waiting for the transition to end the arrows become visible again depending on their current animation progress. The 'animation: none' rule doesn't take effect either because the class selector doesn't override the ID selector.
(Assignee)

Comment 1

5 years ago
Created attachment 673139 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5894

Pointer to Github pull-request
(Assignee)

Updated

5 years ago
Attachment #673139 - Flags: review?(timdream+bugs)
Comment on attachment 673139 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5894

This a dup of Gecko bug 788412. A Gecko bug require Gecko fix. Your fix is good workaround but let's not merge it unless we cannot fix it on the Gecko side in time.
Attachment #673139 - Flags: review?(timdream+bugs)
Thank you for catching this and the quick fix :)
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 788412
(Assignee)

Comment 4

5 years ago
Sorry, but please read the summary again. This is not a duplicate of bug 788412. Bug 788412 is about the arrows being drawn on top of the handler. This bug is about visible arrows between the unlock gesture and the actual unlock.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Sh*t, I overlook the description completely :-/ Sorry about that.
(Assignee)

Comment 6

5 years ago
Comment on attachment 673139 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5894

Let me flag you for review again ;)
Attachment #673139 - Flags: review?(timdream+bugs)
Comment on attachment 673139 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5894

The part I don't like is the !important part, but I guess it's OK.

Can you fill the form below if vingtetun need that?

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #673139 - Flags: review+
Attachment #673139 - Flags: approval-gaia-master?(21)
Attachment #673139 - Flags: review?(timdream+bugs)
(Assignee)

Comment 8

5 years ago
Thank you, Tim! (I always wanted to say that.)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Arrows may flash before unlocking.
Testing completed: 
Risk to taking this patch (and alternatives if risky): Small, almost CSS-only fix.
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #7)
> Comment on attachment 673139 [details]
> Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5894
> 
> The part I don't like is the !important part, but I guess it's OK.
> 

I feel like you with the !important. It make debug painful and usually hide deeper issue.
Comment on attachment 673139 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/5894

Anyway a=me since Tim r+ it and this only add/remove a class.
Attachment #673139 - Flags: approval-gaia-master?(21) → approval-gaia-master+
(Assignee)

Comment 11

5 years ago
(In reply to Vivien Nicolas (:vingtetun) from comment #9)
> > The part I don't like is the !important part, but I guess it's OK.
> 
> I feel like you with the !important. It make debug painful and usually hide
> deeper issue.

I updated the PR and removed the !important. We need to use the IDs #lockscreen-left-arrow and #lockscreen-right-arrow to get rid of it.
https://github.com/mozilla-b2g/gaia/pull/5894

Merged.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 13

5 years ago
The lock screen has been redesigned and this bug is no longer valid. Verified on Unagi build id:20130102070202
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.