Closed Bug 803537 Opened 10 years ago Closed 8 years ago

XHR + blob: URI crashes in workers

Categories

(Core :: DOM: Workers, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla39
blocking-basecamp -
Tracking Status
firefox39 --- fixed

People

(Reporter: baku, Assigned: baku)

Details

(Keywords: crash)

Attachments

(3 files, 1 obsolete file)

Attached file test case
Step to reproduce:

1. create a blob in the main thread
2. get the URI of this blob and
3. share it with a worker
4. the worker does a XHR using this URI
Assignee: nobody → amarchesini
It crashes only when the testcase is loaded from file.
blocking-basecamp: --- → ?
Keywords: crash
This doesn't seem like it'd affect B2G any more than desktop or Fennec and we've shipped those without this fixed. So I wouldn't hold the release for this.

That said, a fix would of course be great. Might even be worth nominating for uplift if it's safe enough since safe crash fixes are always nice to get out to users asap.
blocking-basecamp: ? → -
Attached file test case 2
This new test case doesn't use DOM blob. In order to crash, a generic non http URI is enough.
I'm not actually working on it. Reassigned.
Assignee: amarchesini → nobody
Attached patch crash.patch (obsolete) — Splinter Review
Another debug-only crash.
Attachment #8583197 - Flags: review?(khuey)
Assignee: nobody → amarchesini
Attached patch patchSplinter Review
Attachment #8583197 - Attachment is obsolete: true
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/4c786c42a68a
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
You need to log in before you can comment on or make changes to this bug.