Thunderbird does not retain more than 100 tags

RESOLVED WORKSFORME

Status

Thunderbird
Untriaged
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: Marsh Feldman, Unassigned)

Tracking

16 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

Tried to add tags to emails.




Actual results:

 Sometimes the tags do not even associate with the message. Other times, they appear to associate, but they are gone when I check the email later on.

This does not happen with all tags, only those beginning with a letter at the end of the alphabet. Trial-and-error leads me to believe that the first 100 tags work OK, but the 101st and subsequent tags do not.


Expected results:

I should have been able to associate a tag with the emails.

Comment 1

6 years ago
xref bug 730250
Local mail folder(POP3/Local Folders)? Or IMAP folder?

If local mail folder, read xref'ed bug 730250 comment #17, and check X-Mozilla-Keys: header.

If IMAP folder, read xref'ed bug 730250 comment #17, and get IMAP log, check IMAP level flow for IMAP flag(keyword).
Does your server correctly retain flag(keyword) more than 100?

In any case, check tag defintions in your prefs.js.
Which tag is relevant to your problem?

Comment 3

5 years ago
(In reply to WADA from comment #2)
> Local mail folder(POP3/Local Folders)? Or IMAP folder?
> 
> If local mail folder, read xref'ed bug 730250 comment #17, and check
> X-Mozilla-Keys: header.
> 
> If IMAP folder, read xref'ed bug 730250 comment #17, and get IMAP log, check
> IMAP level flow for IMAP flag(keyword).
> Does your server correctly retain flag(keyword) more than 100?
> 
> In any case, check tag defintions in your prefs.js.
> Which tag is relevant to your problem?
Flags: needinfo?(marsh)
Whiteboard: [closeme 2013-08-01]
(Reporter)

Comment 4

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #3)
> (In reply to WADA from comment #2)
> > Local mail folder(POP3/Local Folders)? Or IMAP folder?
> > 
> > If local mail folder, read xref'ed bug 730250 comment #17, and check
> > X-Mozilla-Keys: header.
> > 
> > If IMAP folder, read xref'ed bug 730250 comment #17, and get IMAP log, check
> > IMAP level flow for IMAP flag(keyword).
> > Does your server correctly retain flag(keyword) more than 100?
> > 
> > In any case, check tag defintions in your prefs.js.
> > Which tag is relevant to your problem?

Sorry, I don't understand all of your question. The mail is accessed via IMAP, but I don't know how to get an IMAP log in TB, how to check IMAP level flow, or what flag(keyword) to use.

I do think the problem has something to do with local limits on the number of tags, and I was told this will be increased over the summer. I'm waiting to test the mail server's reconfiguration before deciding that this is indeed the problem.

For a given profile, where is the prefs.js file typically located on a Mac?

The tags that are relevant to my problem seem to begin with letters towards the end of the alphabet. Typically around "U" tags are not being saved with the message.
Flags: needinfo?(marsh)

Updated

5 years ago
Whiteboard: [closeme 2013-08-01]
(In reply to Marsh Feldman from comment #4)
> I don't know how to get an IMAP log in TB, how to check IMAP level
> flow, or what flag(keyword) to use.

See bug 402793 comment #28 for getting IMAP log.
"Tb's tag == IMAP flag" is stored by "uid store xx +Flags(tagname)" and is retrieved by "uid fetch Flags()". Check such command issued by Tb and response from server in log file by Text Editor.

> For a given profile, where is the prefs.js file typically located on a Mac?

On any OS, profile directory is shown by Help/Trouble Shooting Information, "Profile Folder" row, "Show Folder" button.

Comment 6

5 years ago
(In reply to WADA from comment #5)
> (In reply to Marsh Feldman from comment #4)
> > I don't know how to get an IMAP log in TB, how to check IMAP level
> > flow, or what flag(keyword) to use.
> 
> See bug 402793 comment #28 for getting IMAP log.
> "Tb's tag == IMAP flag" is stored by "uid store xx +Flags(tagname)" and is
> retrieved by "uid fetch Flags()". Check such command issued by Tb and
> response from server in log file by Text Editor.
> 
> > For a given profile, where is the prefs.js file typically located on a Mac?
> 
> On any OS, profile directory is shown by Help/Trouble Shooting Information,
> "Profile Folder" row, "Show Folder" button.
Flags: needinfo?(marsh)
Whiteboard: [closeme 2013-12-20]
(Reporter)

Comment 7

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #6)
> (In reply to WADA from comment #5)
> > (In reply to Marsh Feldman from comment #4)
> > > I don't know how to get an IMAP log in TB, how to check IMAP level
> > > flow, or what flag(keyword) to use.
> > 
> > See bug 402793 comment #28 for getting IMAP log.
> > "Tb's tag == IMAP flag" is stored by "uid store xx +Flags(tagname)" and is
> > retrieved by "uid fetch Flags()". Check such command issued by Tb and
> > response from server in log file by Text Editor.
> > 
> > > For a given profile, where is the prefs.js file typically located on a Mac?
> > 
> > On any OS, profile directory is shown by Help/Trouble Shooting Information,
> > "Profile Folder" row, "Show Folder" button.

Thanks, this is very helpful. However, TB seems to be behaving now, and I'm not sure why.

My original post was over a year ago. Since then TB has been updated several times, my employer's email system underwent a substantial upgrade over the summer, and the other iMap server I generally use (gmail) probably has too.

So I'm going to work with this over then next few weeks and get back to you.

Merry Happy!
Flags: needinfo?(marsh)

Comment 8

5 years ago
Thanks. Let's set WORKSFORME, and if further testing warrants then please reopen the bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2013-12-20]
You need to log in before you can comment on or make changes to this bug.