Range slider thumb doesn't show up

RESOLVED FIXED in mozilla22

Status

()

Core
Layout: Form Controls
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: iweb, Unassigned)

Tracking

16 Branch
mozilla22
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

We did a range slider. This is CSS:


input[type=range] {
	position: relative;
	height: 6px;
	border: none;
	
	padding: 0;
}
	::-webkit-slider-thumb {
		-webkit-appearance: none;
		background: url('range.png') no-repeat 50% 50%;
		
		width: 16px;
		height: 16px;
		
		-webkit-border-radius: 8px;
		-moz-border-radius: 8px;
		border-radius: 8px;
		
		box-shadow: 0 1px 2px rgba(0,0,0,.2), inset 0 -2px 1px rgba(0,0,0,.1), inset 0 0 1px rgba(0,0,0,.8), 0 1px 10px rgba(255,255,255,.5);
	}


Actual results:

The slider thumb doesn't show up and the user can't change its value.


Expected results:

It should show up.
(Reporter)

Comment 1

6 years ago
This is how it should look like: http://imgur.com/fXLxJ
This is how it looks like: http://imgur.com/jA3eD

Comment 2

6 years ago
Could you attach a small html testcase, please. So devs could test.
(Reporter)

Comment 3

6 years ago
Go here: http://pulsir.vlexofree.com/ldr/index.php?menu=version&id=19
Login in with u/p: root/root
Click on the 'Glasaj' button. 
You should see a form. The slider should appear next to the 'Stabilnost' and 'Hardware' categories.

Comment 4

6 years ago
I tried with an old version (Firefox 8) and the slider thumb doesn't show up too.

Did it use to work in previous versions of FF? And in the other browsers?
(Reporter)

Comment 5

6 years ago
Works in Chrome(ium), but it doesn't work in FF3 - FF14.

Comment 6

4 years ago
Created attachment 8464630 [details]
testcase (CSS from comment #0 + input type="range")

nothing: 2012-10-08-03-17-45-mozilla-central-firefox-18.0a1.en-US.linux-x86_64
nothing: 2012-11-20-03-07-39-mozilla-central-firefox-20.0a1.en-US.linux-x86_64
works: 2014-07-29-03-02-02-mozilla-central-firefox-34.0a1.en-US.linux-x86_64

Comment 7

4 years ago
It's fixed, working range:
bad=2013-03-16
good=2013-03-17
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8f5b1f9f5804&tochange=0b052daa913c

Maybe by bug 842179.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
Target Milestone: mozilla21 → mozilla22
You need to log in before you can comment on or make changes to this bug.