Implement Jenkins Improvements in Q2

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: IT-Managed Tools
P1
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: solarce, Assigned: solarce)

Tracking

Details

(Whiteboard: [tracker][2013q2])

(Assignee)

Description

6 years ago
There are a number of improvements to be made to Jenkins by the webops team, we're going to review this at the beginning of November and assess workload/progress of existing Q4 goals
(Assignee)

Updated

6 years ago
Summary: Jenkins Improvements in Q4 → Review Jenkins Improvements in Q4 (2012-11)
(Assignee)

Updated

6 years ago
Blocks: 800574
(Assignee)

Updated

6 years ago
Blocks: 800180
(Assignee)

Updated

6 years ago
Whiteboard: [waiting][webops review 2012-11][triaged 20121019] → [waiting][webops review 2012-11][triaged 20121019][tracker]
(Assignee)

Updated

6 years ago
Blocks: 799826
(Assignee)

Updated

6 years ago
Blocks: 799802
(Assignee)

Updated

6 years ago
Blocks: 805996
(Assignee)

Updated

6 years ago
Depends on: 811380
(Assignee)

Updated

6 years ago
Depends on: 811452
(Assignee)

Updated

6 years ago
Blocks: 798155
Duplicate of this bug: 810540
(Assignee)

Updated

6 years ago
Blocks: 826549
(Assignee)

Updated

6 years ago
No longer blocks: 826549
Summary: Review Jenkins Improvements in Q4 (2012-11) → Review Jenkins Improvements in Q1
Whiteboard: [waiting][webops review 2012-11][triaged 20121019][tracker] → [tracker][2013q1?]
(Assignee)

Updated

6 years ago
Blocks: 826549
(Assignee)

Updated

5 years ago
Blocks: 827615
(Assignee)

Updated

5 years ago
Depends on: 834262
(Assignee)

Updated

5 years ago
Assignee: server-ops-webops → bburton
Priority: P3 → P1
Summary: Review Jenkins Improvements in Q1 → Implement Jenkins Improvements in Q1
Whiteboard: [tracker][2013q1?] → [tracker][2013q1]
(Assignee)

Updated

5 years ago
Duplicate of this bug: 837866
(Assignee)

Updated

5 years ago
Depends on: 838284
(Assignee)

Updated

5 years ago
Depends on: 837521
(Assignee)

Comment 3

5 years ago
This was deferred to Q2
Summary: Implement Jenkins Improvements in Q1 → Implement Jenkins Improvements in Q2
Whiteboard: [tracker][2013q1] → [tracker][2013q2]
(Assignee)

Updated

5 years ago
Assignee: bburton → server-ops-webops
(Assignee)

Updated

5 years ago
Assignee: server-ops-webops → bburton
(Assignee)

Updated

5 years ago
Component: Server Operations: Web Operations → WebOps: IT-Managed Tools
Product: mozilla.org → Infrastructure & Operations
Filed bug 925223 regarding Puppet breakage caused by a commit referencing this bug:


Author: bburton@mozilla.com <bburton@mozilla.com>
Date:   Tue Sep 24 04:30:49 2013 +0000

    cleanup of unused jenkins manifest, bug 803599
    
    svn+ssh://svn.mozilla.org/sysadmins/puppet/trunk@75572
(Assignee)

Comment 5

4 years ago
The state of jenkins has improved a lot since this bug was originally filed, the ongoing issues we had with jenkins no longer exist (some load moved to dedicated jenkins servers for projects, other load moved to travis-ci), and restart times were improved dramatically due to job cleanup
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.