Closed Bug 803613 Opened 7 years ago Closed 7 years ago

java.lang.NullPointerException: at org.mozilla.gecko.gfx.ScreenshotLayer$ScreenshotImage.setBitmap(ScreenshotLayer.java)

Categories

(Firefox for Android :: Toolbar, defect, critical)

19 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 19
Tracking Status
firefox18 --- unaffected
firefox19 --- fixed

People

(Reporter: scoobidiver, Assigned: kats)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash])

Crash Data

Attachments

(2 files)

It first appeared in 19.0a1/20121019 and has been hit by two users. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb573b9307e5&tochange=0ff60bfb3442

Here is a crash report: bp-c7858491-7894-4bb1-94b2-4e8932121019.

java.lang.NullPointerException
	at org.mozilla.gecko.gfx.ScreenshotLayer$ScreenshotImage.setBitmap(ScreenshotLayer.java:146)
	at org.mozilla.gecko.gfx.ScreenshotLayer.setBitmap(ScreenshotLayer.java:42)
	at org.mozilla.gecko.gfx.LayerRenderer.setCheckerboardBitmap(LayerRenderer.java:131)
	at org.mozilla.gecko.ScreenshotHandler$2.run(ScreenshotHandler.java:355)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.gfx.ScreenshotLayer%24ScreenshotImage.setBitmap%28ScreenshotLayer.java%29
Likely a regression from bug 779511. Looks like a race - the screenshot bitmap is coming in after the screenshot layer is destroyed. I'll put together a fix.
Assignee: nobody → bugmail.mozilla
Blocks: 779511
Attached patch NPE fixSplinter Review
Attachment #673380 - Flags: review?(blassey.bugs)
Attachment #673380 - Flags: review?(blassey.bugs) → review+
Attachment #673381 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/e4fa894b7348
https://hg.mozilla.org/mozilla-central/rev/666a61b83149
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
You need to log in before you can comment on or make changes to this bug.