All users were logged out of Bugzilla on October 13th, 2018

Investigate thumbnail regressions

RESOLVED DUPLICATE of bug 803687

Status

()

RESOLVED DUPLICATE of bug 803687
6 years ago
6 years ago

People

(Reporter: kats, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I noticed that bug 787765 possibly regressed the fix to bug 776906. Specifically, Tab.getThumbnailWidth and Tab.getThumbnailHeight always returned even numbers so that cairo always got a 4-aligned stride width and actually allocated the surface to draw the thumbnail. Bug 787765 moved that code and removed part of it, so now that constraint doesn't look like it holds any more. I don't have a Nexus 7 any more so I can't check if bug 776906 has regressed as a result. However there is at least one thumbnail regression that looks like a stride length mismatch (no bug filed yet but bnicholson has STR) so this code needs looking at.
The concern I had was fixed by wesj's patch on bug 803687.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 803687
You need to log in before you can comment on or make changes to this bug.