Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Remove the hack around otoro orientation issue when capturing still images

RESOLVED FIXED

Status

Firefox OS
Gaia
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cjones, Assigned: m1)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking-basecamp:+, firefox17 fixed, firefox18 fixed)

Details

(Whiteboard: [fota] QARegressExclude)

Attachments

(1 attachment, 1 obsolete attachment)

We should normalize all these device quirks at the platform level.  We've already busted another device from the hack.
(Assignee)

Comment 1

5 years ago
Created attachment 673505 [details] [diff] [review]
Normalize camera sensor orientation
(Assignee)

Comment 2

5 years ago
PR for gaia portion: https://github.com/mozilla-b2g/gaia/pull/5909
(Assignee)

Comment 3

5 years ago
Try run: https://tbpl.mozilla.org/?tree=Try&rev=dbf93f3bc829
(Assignee)

Comment 4

5 years ago
Otoro/Unagi quirks already landed:
https://github.com/mozilla-b2g/android-device-otoro/commit/b456d081241f5c4bbf13d8f0e79ab140cc45a4f1
https://github.com/mozilla-b2g/android-device-unagi/commit/86e1911d940f1cfdad661603a305d07f3d041bb8
(Assignee)

Updated

5 years ago
blocking-basecamp: --- → ?
(Assignee)

Updated

5 years ago
Duplicate of this bug: 802785
This blocks correctly-oriented photos on the commercial phone.
blocking-basecamp: ? → +
(Assignee)

Updated

5 years ago
Attachment #673505 - Flags: review?(jones.chris.g)
Attachment #673505 - Flags: review?(jones.chris.g) → review+
The PR of course looks fine, but please give us until Monday to land until we can work out something for otoro/unagi dogfooders.  Sorry about that.
Assignee: nobody → mvines
(Assignee)

Comment 8

5 years ago
Created attachment 674898 [details] [diff] [review]
Trivial rebase

Carrying r+ forward
Attachment #673505 - Attachment is obsolete: true
Attachment #674898 - Flags: review+
(Assignee)

Updated

5 years ago
Attachment #673505 - Attachment is obsolete: false
(Assignee)

Comment 9

5 years ago
Comment on attachment 674898 [details] [diff] [review]
Trivial rebase

nm.  can't drive hg properly yet...
Attachment #674898 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
Whiteboard: [checkin-needed:aurora]
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/450f060c4577
Note to Moz dogfooders / bisecters: this patch and the associated gaia commit will result in rotated images being captured by the cameras on otoro and unagi.  That's 100% expected and understood.  You won't see this bug in full flashes.

mvines was kind enough to land that workaround for us.  However, we need to ship this workaround in a FOTA update to dogfooders.  (Or have them push a new file to device.)
I'll land this on Aurora after it lands on m-c. No need to request checkin on that part as long as it's got blocking-basecamp+ or approval-aurora+.
Keywords: checkin-needed
Whiteboard: [checkin-needed:aurora]
(Assignee)

Comment 13

5 years ago
(In reply to Chris Jones [:cjones] [:warhammer] from comment #11)
> ... land that workaround for us.  

Ref:
https://github.com/mozilla-b2g/android-device-otoro/commit/b456d081241f5c4bbf13d8f0e79ab140cc45a4f1
https://github.com/mozilla-b2g/android-device-unagi/commit/86e1911d940f1cfdad661603a305d07f3d041bb8
Also FTR, the FOTA wheels are in motion.
https://hg.mozilla.org/mozilla-central/rev/450f060c4577
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
https://hg.mozilla.org/releases/mozilla-aurora/rev/ea122969082d
status-firefox17: --- → fixed
status-firefox18: --- → fixed
Duplicate of this bug: 805737
Duplicate of this bug: 805782
Duplicate of this bug: 806356
Whiteboard: [fota]

Updated

5 years ago
Depends on: 806582

Comment 20

5 years ago
Defect is verified as fixed using the Unagi device, build 20130114073222. 
Needs to be verified on an Otoro device.

Updated

5 years ago
Whiteboard: [fota] → [fota] QARegressExclude
You need to log in before you can comment on or make changes to this bug.