offline message refers to "file" menu - doesn't exist

VERIFIED FIXED

Status

defect
P3
normal
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: hwine, Assigned: Margaret)

Tracking

({b2g-testdriver, unagi})

Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

Details

Attachments

(1 attachment)

In FF - no data connection - try to reload a page. Error message reads "This document cannot be displayed while offline. To go online, uncheck Work Offline from the File menu"

There is no file menu :(

Asset 14019
blocking-basecamp: --- → ?
Component: Gaia → Gaia::Browser
Per triage: this should block, should be a matter of overriding netError.dtd like mobile does.  I would suggest starting from that version: http://mxr.mozilla.org/mozilla-central/source/mobile/locales/en-US/overrides/netError.dtd
blocking-basecamp: ? → +
Priority: -- → P3
Assignee

Comment 2

7 years ago
It looks like there's already a b2g override:
http://mxr.mozilla.org/mozilla-central/source/b2g/locales/en-US/chrome/overrides/netError.dtd#62

I wonder why it's not working. Maybe it's some issue with the makefile?
http://mxr.mozilla.org/mozilla-central/source/b2g/locales/jar.mn#16
Assignee

Comment 3

7 years ago
Oh, this string isn't in netError.dtd, it's in appstrings.properties:
http://mxr.mozilla.org/mozilla-central/source/dom/locales/en-US/chrome/appstrings.properties#18

We do have an override file for that:
http://mxr.mozilla.org/mozilla-central/source/b2g/locales/en-US/chrome/overrides/appstrings.properties#19

But we fail to put it in jar.mn. I'll make a patch.
Assignee: nobody → margaret.leibovic
Assignee

Comment 4

7 years ago
Posted patch patchSplinter Review
Choosing philikon for review because he's the person in hg blame responsible for these files :)

I tested this and verified it fixes the string issue for offline mode. Probably fixes some other string bugs, too!
Attachment #676355 - Flags: review?(philipp)
(In reply to Margaret Leibovic [:margaret] from comment #4)
> Choosing philikon for review because he's the person in hg blame responsible
> for these files :)

hg fail... I merely hg copy'd them from XUL fennec! Also, I filed this bug quite a while ago... sigh (bug 787435).
Duplicate of this bug: 787435
(In reply to Mike Connor [:mconnor] from comment #1)
> Per triage: this should block

Lulz... bug 787435 was minused :)
Comment on attachment 676355 [details] [diff] [review]
patch

Review of attachment 676355 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, I guess that's a good step in the right direction, but e.g.

  netOffline=Firefox is currently in offline mode and can't browse the Web.

isn't exactly a good string either. Keep in mind, this screen will appear also for app iframes. Worst case these strings will do, but ideally a part 2 patch or follow-up bug should revise them, too.

Then again, who knows whether they'd get into Aurora. Plus, are we actually changing the locale correctly for Gecko-based pages?
Attachment #676355 - Flags: review?(philipp) → review+
Duplicate of this bug: 805564
Assignee

Updated

7 years ago
Blocks: 807152
Assignee

Comment 10

7 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/27978aa4d430

I filed bug 807152 as a follow-up, since the strings could use some UX input before being updated.
https://hg.mozilla.org/mozilla-central/rev/27978aa4d430
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 14

6 years ago
verified it on Unagi build 201301140703222
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.