Last Comment Bug 803775 - chat window title bar blurry
: chat window title bar blurry
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: Firefox 19
Assigned To: :Felipe Gomes (needinfo me!)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-19 19:48 PDT by Mary
Modified: 2012-12-04 14:34 PST (History)
4 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
+
verified


Attachments
Blurry font (29.29 KB, image/tiff)
2012-10-19 19:48 PDT, Mary
no flags Details
Patch (1.65 KB, patch)
2012-10-24 20:07 PDT, :Felipe Gomes (needinfo me!)
MattN+bmo: review+
gavin.sharp: approval‑mozilla‑aurora+
gavin.sharp: approval‑mozilla‑beta+
Details | Diff | Review

Description Mary 2012-10-19 19:48:25 PDT
Created attachment 673508 [details]
Blurry font

The font used for user names on the messenger dialogue box has a shadow that makes names look blurry :(
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-24 15:44:45 PDT
Shane/Jared, this is a problem with Facebook's content, right?
http://cl.ly/image/3A1b2b2Q322Y
Comment 2 :Felipe Gomes (needinfo me!) 2012-10-24 17:54:49 PDT
no, that title is ours, in a <label> element. Mary: do you use a custom Firefox theme that might add text-shadow to tabs?
Comment 3 Mary 2012-10-24 17:58:05 PDT
Hi Felipe and team:  Thanks for looking into this.  I'm on Mac OS + using the Flag themes we created for the Olympics.  Thanks!
Comment 4 :Felipe Gomes (needinfo me!) 2012-10-24 20:07:54 PDT
Created attachment 674956 [details] [diff] [review]
Patch

Thank you Mary for the info :)

Color and text-shadow is inherited everywhere when a Persona is set, so here where we change the color to a different value we should also clear the text-shadow
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-24 20:22:38 PDT
Comment on attachment 674956 [details] [diff] [review]
Patch

[Triage Comment]
let's get this on aurora+beta too.
Comment 7 Mary 2012-10-24 21:44:58 PDT
Fantastic - thanks all!  If it's not been clear before - Social API + FB messenger are awesome.  Thank you, thank you!
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-10-25 05:19:23 PDT
https://hg.mozilla.org/mozilla-central/rev/6c392aeb7d11
Comment 9 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-12-04 14:34:22 PST
Confirmed that I can't reproduce this bug anymore.

Note You need to log in before you can comment on or make changes to this bug.