Allow auto-complete of the email address field in Persona (the identity service)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: mihai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

I reviewed persona identity service and I would like to improve it .  I see no option to change this to "feature request/improvement" so fill it as a bug.

 


Actual results:

We are integrating persona in our identity / authentication service and would like to suggest a feature which is "autocomplete email address" . This is how we think it should work : 
  The client provides an email address through our interface . We detect it that is "persona" enabled (based on its domain name) and we pop-up the persona IDP authentication  UI  so he can type again his email  and password to authenticate .


Expected results:

The problem is that now the user has to fill / provide again his email address(and  the password of course)  so I think it would be an improvement if we can autocomplete the email address that it previously provided us so it won't have to type it again.
Hi, you could send this to the mailing list dev-identity@lists.mozilla.org
(https://lists.mozilla.org/listinfo/dev-identity) for discussion?

Alternatively, https://github.com/mozilla/browserid/issues where we generally deal with Persona issues. 

Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.