If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Send Link Context Menu for Hyperlinks

RESOLVED WONTFIX

Status

()

Firefox
Untriaged
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: dombusser, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 673530 [details]
Untitled-2.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

Right click a link


Actual results:

Menu entry "Send link" is missing


Expected results:

Menu entry "Send link" should be present. This functionality has been removed for the On-Page Context Menu and replaced by File > Email Link, but there is no equivalent functionality present anymore for sending hyperlinks directly from websites without visiting them first.

Could be fixed as easily as appending a "Email Link" entry to the Hyperlink Context Menu, just like it is in place with Image Context Menus.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 786185
(Reporter)

Comment 2

5 years ago
(In reply to Kevin Brosnan [:kbrosnan] from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 786185 ***

Dear Kevin, please note that this issue is regarding the context menu for right-clicking a hyperlink, not the main context menu like in bug 786185.
While the functionality of sending a link via the main context menu has been replaced by File -> Email Link, there is currently no way of sending a hyperlink's address without visiting the site first.
(Reporter)

Updated

5 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to dombusser from comment #2)
> (In reply to Kevin Brosnan [:kbrosnan] from comment #1)
> there is currently no way of sending a
> hyperlink's address without visiting the site first.

"Copy Link Location" in context menu...
(Reporter)

Comment 4

5 years ago
(In reply to Virtual_ManPL [:Virtual] from comment #3)
> (In reply to dombusser from comment #2)
> > (In reply to Kevin Brosnan [:kbrosnan] from comment #1)
> > there is currently no way of sending a
> > hyperlink's address without visiting the site first.
> 
> "Copy Link Location" in context menu...

Like I said, "Sending". Not "Copying".
So it's dupe of bug #786185 = WONTFIX ...

Comment 6

5 years ago
No it isn't, because it refers the the context menu of a *link*, not of a *page*. Please read the description provided above which makes this very clear.
It's still WONTFIX as we don't want to bloat menus with not widely used features.

Comment 8

5 years ago
(In reply to Virtual_ManPL [:Virtual] from comment #7)
> It's still WONTFIX as we don't want to bloat menus with not widely used
> features.

Dear Virtual_ManPL: YOU may think this very handy function isn't widely used, but we Firefox users seem to think differently, judging from the fact that there are now seven bugs created for this issue so far, with a number of very unhappy people posting comments on them.
Changes are always problematic. Look on change with image background. But if you want to use this feature install an addon which re-add this function. Also I know not think that this feature isn't widely used per Test Pilot statistic. Mozilla dev team decided that menus have to be minimalistic and small bug dupes (about 10) or small comments (no more than 100) compared to 125 million people using Firefox won't change Mozilla mind about it.

So believe or not, this bug sill be a WONTFIX.
(In reply to Virtual_ManPL [:Virtual] from comment #9)
> Look on change with image background
and also "Tabs on bottom" will be removed in near future.

Comment 11

5 years ago
(In reply to Virtual_ManPL [:Virtual] from comment #9)
> Changes are always problematic. Look on change with image background. But if
> you want to use this feature install an addon which re-add this function.
> Also I know not think that this feature isn't widely used per Test Pilot
> statistic. Mozilla dev team decided that menus have to be minimalistic and
> small bug dupes (about 10) or small comments (no more than 100) compared to
> 125 million people using Firefox won't change Mozilla mind about it.
> 
> So believe or not, this bug sill be a WONTFIX.

Test Pilot is not representative of Firefox users. Can you imagine what sort of user will go to the Labs site, install an addon, and participate voluntarily in these studies? Not the ordinary Firefox user.

Also, such studies only count how many users use something, not how important the feature is to those who *do* use it.

Nearly all software developers know (like myself) that these sorts of studies are biased and *only* should be used as a springboard to further research and direct feedback from ordinary users within the wider user base.

This was a poor decision by Mozilla and especially frustrating given they have been in the game long enough to have known better. Even Microsoft have learned this kind of lesson now.

Comment 12

5 years ago
(In reply to Mark Jones from comment #11)
> (In reply to Virtual_ManPL [:Virtual] from comment #9)
> > Changes are always problematic. Look on change with image background. But if
> > you want to use this feature install an addon which re-add this function.
> > Also I know not think that this feature isn't widely used per Test Pilot
> > statistic. Mozilla dev team decided that menus have to be minimalistic and
> > small bug dupes (about 10) or small comments (no more than 100) compared to
> > 125 million people using Firefox won't change Mozilla mind about it.
> > 
> > So believe or not, this bug sill be a WONTFIX.
> 
> Test Pilot is not representative of Firefox users. Can you imagine what sort
> of user will go to the Labs site, install an addon, and participate
> voluntarily in these studies? Not the ordinary Firefox user.
> 
> Also, such studies only count how many users use something, not how
> important the feature is to those who *do* use it.
> 
> Nearly all software developers know (like myself) that these sorts of
> studies are biased and *only* should be used as a springboard to further
> research and direct feedback from ordinary users within the wider user base.
> 
> This was a poor decision by Mozilla and especially frustrating given they
> have been in the game long enough to have known better. Even Microsoft have
> learned this kind of lesson now.


I agree completely.  You said what I was thinking much better than I could have said it. 

Also, now they're planning to remove yet another feature that I use - tabs on bottom!

Comment 13

5 years ago
I've submitted the following two feedback items to Firefox:

Sent to "Firefox Made Me Sad" at http://input.mozilla.org/en-US/feedback#sad:
You still haven't put "send link" back onto the right-click context menu - see bugs 239307, 786185, 800565, 803805, 804124, 804424, 805134, and 805949


Sent to "I Have an Idea for Firefox" at http://input.mozilla.org/en-US/feedback#idea:
Put "send link" back onto the right-click context menu - see bugs 239307, 786185, 800565, 803805, 804124, 804424, 805134, and 805949

Feel free to do the same - you're welcome to cut-and-paste the above messages.

Updated

5 years ago
Duplicate of this bug: 807874

Comment 15

5 years ago
As written before, developers have decided that they will not fix this request.
Hence this is a WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 814711
Workaround: https://addons.mozilla.org/de/firefox/addon/send-link-in-context-menu/?src=search
You need to log in before you can comment on or make changes to this bug.