Cannot run simoultaneously firefox on multiple pc's on linux

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: paolobenve, Unassigned)

Tracking

15 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:15.0) Gecko/20100101 Firefox/15.0.1
Build ID: 20120907231835

Steps to reproduce:

Ubuntu 12.04, but the issue has been present for many years.

I want to run firefox on another linux pc with the command

$ ssh -X otherpc firefox

This command asks me the ssh password for otherpc, but...


Actual results:

1. If no firefox instance is running, firefox is run on otherpc (OK).

2. If firefox is running on my host, the command opens another firefox instance on my host, not on otherpc (bug)

The same thing happens inversely.

If I run firefox on my host:

1. If no firefox instance is running on otherpc, firefox is run on my host (OK)

2. if I have a firefox instance running on otherpc, another instance of firefox on otherpc is run (bug)

In other words, It's not possible to run simultaneously firefox on my host and on another pc with ssh -X

I verified that this behaviour happens only with firefox, and happens on various ubuntu pc I have.





Expected results:

The user should be able to run simultaneously firefox on his host and on another pc with ssh -X
(Reporter)

Updated

6 years ago
Summary: problems running firefox on multiple pc's on linux → Cannot run simoultaneously firefox on multiple pc's on linux
Use a combination of -P and -no-remote see https://developer.mozilla.org/en/Command_Line_Options#-no-remote
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

6 years ago
Actually the use of the -no-remote options resolves the issue, but I'm reopening the bug because I think that firefox should behave like all other apps.

There isn't any reason why firefox launched with "ssh -X otherhost" should behave differently than all other applications.

The use of -P isn't actually necessary in order to resolve the issue.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
This is the expected behavior. Profiles are not able to be accessed at the same time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → INVALID

Comment 4

6 years ago
It was originally a design decision in Netscape - it allows you to quickly open new windows, without starting new copies of the executable with all the extra network traffic etc ... And if those windows can be run in the same executable, they also share other resource like the cache and cookies. Otherwise you would need to login more than once per website (like if you use 'New Session' in Internet Explorer).

But the biggest reason that -no-remote can't be removed right now, is that all those executables will normally share a common profile, and that would prevent you from opening new browsers. People would complain immediately, not understanding why they would need to use -P (and create extra profiles).
You need to log in before you can comment on or make changes to this bug.