The default bug view has changed. See this FAQ.

Block script from seeing clicks on the plugin placeholders

RESOLVED FIXED

Status

SeaMonkey
UI Design
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

unspecified

SeaMonkey Tracking Flags

(seamonkey2.14 fixed, seamonkey2.15 fixed, seamonkey2.16 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Bug 787619 shows a case where a media player script expects the plugin to block clicks and because the click-to-play placeholder does not the script thinks you're still seeing the preview image and recreates the plugin.
(Assignee)

Comment 1

5 years ago
Created attachment 673569 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #673569 - Flags: review?(iann_bugzilla)

Updated

5 years ago
Attachment #673569 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 2

5 years ago
Comment on attachment 673569 [details] [diff] [review]
Proposed patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Unable to click-to-play some plugins
Testing completed (on m-c, etc.): Similar patch applied to Firefox
Risk to taking this patch (and alternatives if risky): Very low
String changes made by this patch: None
Attachment #673569 - Flags: approval-comm-beta?
Attachment #673569 - Flags: approval-comm-aurora?

Updated

5 years ago
Attachment #673569 - Flags: approval-comm-beta?
Attachment #673569 - Flags: approval-comm-beta+
Attachment #673569 - Flags: approval-comm-aurora?
Attachment #673569 - Flags: approval-comm-aurora+
(Assignee)

Comment 3

5 years ago
Pushed comm-central changeset cb0c2eab4492.
https://hg.mozilla.org/releases/comm-aurora/rev/5a3bce57a4be
https://hg.mozilla.org/releases/comm-beta/rev/4b325b90838c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
status-seamonkey2.14: --- → fixed
status-seamonkey2.15: --- → fixed
status-seamonkey2.16: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.