The 'weekly downloads' number on statistics page is different than the one shown on in reviewer tools (and lookup tool)

RESOLVED FIXED in 2012-11-01

Status

--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: eviljeff, Assigned: andy+bugzilla)

Tracking

2012-11-01
Points:
---

Details

(Reporter)

Description

6 years ago
The weekly downloads count is shown in the reviewer tools on the review page.  Its also shown in the statistics page (and also in the lookup tool).  All three of these numbers are different so that indicates at least 2 of them are incorrect.

e.g.
https://marketplace.mozilla.org/reviewers/apps/review/twitter (136)
https://marketplace.mozilla.org/app/twitter/statistics/?last=7 (386)
https://marketplace.mozilla.org/lookup/app/393011/summary (155)

Incidentally, the total downloads are also different (bug 790298, logged last month): 4, 1623 and 323 respectively.

Primarily I'm logging this because I'm currently using the weeklydownloads field in the addons table in a report I produce for Business Development and the number I'm using needs to be correct.
(Assignee)

Comment 1

6 years ago
Lookup app - uses the Installed table. This is the correct way at this time (may change).

App statistics - uses the Installed table, but does its own count. Those two should probably changed to use the same API.

Reviewers - uses the weekly downloads table, that data comes from metrics, why it's being populated at all, I don't know.
(Reporter)

Comment 2

6 years ago
with todays stats:

(In reply to Andy McKay [:andym] from comment #1)
> Lookup app - uses the Installed table. This is the correct way at this time
> (may change).

211

> App statistics - uses the Installed table, but does its own count. Those two
> should probably changed to use the same API.

0+507+818+220+58+56+16= 1,675

> Reviewers - uses the weekly downloads table, that data comes from metrics,
> why it's being populated at all, I don't know.

201

- the daily numbers that the stats dashboard uses have jumped like I would have expected since the launch - the others less so.
andy <3 stats

Andy: let's do make these use a number from a single place.  As you know we're going to be overhauling metrics so don't go too far down the rabbit hole, but 'weekly downloads' sounds like something that we should get right regardless of what other stats we end up collecting.
Assignee: nobody → amckay
Target Milestone: --- → 2012-11-01
Duplicate of this bug: 790298
(Assignee)

Comment 5

6 years ago
As it turns out I added a weekly downloads cron in that reads from Installed. So I think these are actually all right and there's not much to be done here. I changed the lookup tool to use the weekly_download value so it tallies up with the other pages. Bear in mind the weekly_download is populated from a cron, so is correct at that point in time.

https://github.com/andymckay/zamboni/commit/89c11b
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.