Closed Bug 803882 Opened 7 years ago Closed 7 years ago

browser_webconsole_bug_595934_message_categories.js use of waitForSuccess may be broken

Categories

(DevTools :: Console, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 797294

People

(Reporter: graememcc, Unassigned)

References

Details

Each test in browser_webconsole_bug_595934_message_categories.js uses the waitForSuccess function in devtools/webconsole/test/head.js to poll for success with a 5s timeout. There's 16 of them, so that's 80 seconds.

Nobody tells the browser-chrome harness, which kills you after only 30s.

Haven't looked at other webconsole/ tests that timeout, so can't say whether it's just a case of sticking a requestLongerTimeout call here, or if waitForSuccess itself needs fixed.
Ah, Rob Campbell is way ahead of me - it looks like there's already a fix for this very problem in fx-team waiting to be merged.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797294
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.