Unable to login with Sync

RESOLVED INVALID

Status

Cloud Services
Firefox Sync: UI
RESOLVED INVALID
6 years ago
7 months ago

People

(Reporter: Derrick Lambert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme-sync.next][sync:setup])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121020030554

Steps to reproduce:

When I updated from the Aurora to the Nightly version of Firefox I was signed out of Sync. I didnt think that was a problem because I thought I could just login to Sync to get all my bookmarks and Personas back. However I am not able to log back into sync. I went into the Sync menu and clicked I Have an Account, then click I don't have the device with me (because I am using the device that was previously paired with Sync) then typed in Username and Password then I have lost my other device to get a new Recovery Key to login because I never saved mine. Then I tried clicking next but as many times as I tried clicking it it wouldn't do anything and continue the login process.


Actual results:

Nothing, Wouldn't continue the login process.


Expected results:

Logged into Sync and fetched my bookmarks and Personas from the Server. I am still unable to login. I just manually re-bookmarked my favorite websites.
(Reporter)

Updated

6 years ago
Version: Trunk → 19 Branch
(Reporter)

Comment 1

6 years ago
I was eventually able to sign it but the process is still very glitchy
Component: Untriaged → Firefox Sync: UI
Product: Firefox → Mozilla Services
Version: 19 Branch → unspecified

Comment 2

6 years ago
It's the same here. Once logged out at sync, it's impossible to log in again. (I have only one device with sync, so i can not pair my device and I never take a look on the Recovery Key.)
(In reply to tom.so from comment #2)
> It's the same here. Once logged out at sync, it's impossible to log in
> again. (I have only one device with sync, so i can not pair my device and I
> never take a look on the Recovery Key.)

You shouldn't use Sync the way you're using it. It's not a backup of your profile, and if you expect to be have a chance of using it to recover your data, you will need the Recovery Key.

There is essentially no point in using Sync with only one device.
(In reply to drekryan from comment #1)
> I was eventually able to sign it but the process is still very glitchy

Yup, the setup wizard needs some work.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [closeme-sync.next][sync:setup]

Comment 5

6 years ago
I just did it for moztrap. I had to log off once, then I noticed this.

Comment 6

7 months ago
Closing, we don't use that authentication system anymore.
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.