The default bug view has changed. See this FAQ.

"gdata-provider.xpi: The add-on downloaded from ftp.mozilla.org could not be installed because it appears to be corrupt."

RESOLVED FIXED

Status

Calendar
Provider: GData
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

Details

(URL)

Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/19.0 Firefox/19.0 SeaMonkey/2.16a1 ID:20121019003003 c-c:bd22a204044b m-c:0ff60bfb3442

Reproducible: Always

Trying to install the latest comm-central build of gdata-provider.xpi.

Tried:
  (a) Downloading from ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-comm-central/linux64-xpi using the command-line ftp utility, then installing from hard disk using "Install add-on from Fileā€¦" in add-on manager
  (b) Browsing to http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/linux64-xpi/ and clicking gdata-provider.xpi
  (c) Browsing to http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-central/linux64-xpi-linux64/1350813600/ and clicking gdata-provider.xpi

Lightning installs with no problems at step (a).
For gdata-provider, in all cases the result is the same: An error message appears, saying "The add-on downloaded from ftp.mozilla.org could not be installed because it appears to be corrupt.".

Updated

5 years ago
Depends on: 799643
Today I could install http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-central/gdata-provider-0.20pre.en-US.linux-x86_64.xpi with no error. The W32 and W64 builds in the same directory look bizarre, though. Can someone test them?

Comment 2

5 years ago
Just did a fresh install of TB from thunderbird/nightly/latest-comm-central/thunderbird-19.0a1.en-US.win32.installer.exe followed by calendar/lightning/nightly/latest-comm-central/lightning-2.1a1.en-US.win32.xpi. The nightly win32 for gdata is gdata-provider-.en-US.win32.xpi (note the missing "0.20pre" - the same is true for the win64 package).

Upon attempting installation of GData (after restarting following the Lightning install), I get an error at the top of the window which I cannot read (different bug to file for that). The log says:

Timestamp: 11/2/2012 9:10:32 PM
Warning: WARN addons.xpi: Invalid XPI: Error: No version in install manifest
Source File: resource://gre/modules/XPIProvider.jsm
Line: 748

Timestamp: 11/2/2012 9:10:33 PM
Warning: WARN addons.xpi: Download failed: Error: No version in install manifest
Source File: resource://gre/modules/XPIProvider.jsm
Line: 748

So it does indeed look like broken packaging. I haven't looked more closely, nor have I had an opportunity to test under win64 (need to find a VM of that running somewhere around here).

Comment 3

5 years ago
The problem has been fixed already in Bug 799643, the same bug that caused it. Todays build should get the correct version number.

Comment 4

5 years ago
Indeed; timing is everything. I was thinking that the builds tested here were *after* Phillip's push. Apologies for the bug spam!
Resolving in the light of comment #1 and comment #4. Feel free to REOPEN (with a comment saying why) if there is something more to fix in this bug.

IIUC the fix is in comm-central changeset f919289ef9c8
Status: NEW → RESOLVED
Last Resolved: 5 years ago
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.