collectstats.pl uses ":utf8" with binmode instead of ":encoding(UTF-8)"

RESOLVED WONTFIX

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: James Mike DuPont, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120310193349

Steps to reproduce:

perlcritic



Expected results:

patch here 
https://code.launchpad.net/~jamesmikedupont/bugzilla/trunk/+merge/130705
(Reporter)

Updated

5 years ago
Summary: perlcritic I/O layer ":utf8" used at line 235, column 9. Use ":encoding(UTF-8)" to get strict validation. → collectstats.pl perlcritic I/O layer ":utf8" used. Use ":encoding(UTF-8)" to get strict validation.

Comment 1

5 years ago
It's fine to use :utf8 in collectstats.pl. We have full control on files used by this script as they are generated by Bugzilla. So this is not a bug.

As said elsewhere, we don't really care about complains from perlcritic. It has no idea what the context is and "best practice" is a pretty subjective definition.
Severity: normal → enhancement
Summary: collectstats.pl perlcritic I/O layer ":utf8" used. Use ":encoding(UTF-8)" to get strict validation. → collectstats.pl uses ":utf8" with binmode instead of ":encoding(UTF-8)"

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.