The default bug view has changed. See this FAQ.

Convert mailnews/base/content/folderWidgets.xml to mailServices.js

RESOLVED FIXED in Thunderbird 19.0

Status

MailNews Core
Backend
--
minor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: aceman, Assigned: aceman)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 19.0
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

5 years ago
var session = Cc["@mozilla.org/messenger/services/session;1"].
let acctMgr = Cc["@mozilla.org/messenger/account-manager;1"].
var session = Cc["@mozilla.org/messenger/services/session;1"].
var servers = Cc["@mozilla.org/messenger/account-manager;1"].
var session = Cc["@mozilla.org/messenger/services/session;1"]
(Assignee)

Comment 1

5 years ago
Created attachment 673726 [details] [diff] [review]
patch

I intentionally leave out the account-manager service in _ensureInitialized() because that is covered in bug 749200.
Attachment #673726 - Flags: review?(neil)
Attachment #673726 - Flags: feedback?(philip.chee)

Comment 2

5 years ago
Comment on attachment 673726 [details] [diff] [review]
patch

I'm not sure where SeaMonkey uses this but I did track down one use in the New Folder dialog.

Unfortunately there were a number of JavaScript exceptions in the Error Console that may or may not have been responsible for the accounts being duplicated.
Attachment #673726 - Flags: review?(neil) → review-
(Assignee)

Comment 3

5 years ago
It is also used in the Account manager for the folder targets (junk/copies/archive).

But I didn't understand what the problem is you see. What is being duplicated and what are the exceptions?
(Assignee)

Comment 4

5 years ago
Comment on attachment 673726 [details] [diff] [review]
patch

Ian, can you please try in Seamonkey if you also see Neil's problems?
Attachment #673726 - Flags: feedback?(iann_bugzilla)

Comment 5

5 years ago
Comment on attachment 673726 [details] [diff] [review]
patch

I see this too in the new folder dialog.
STR
1/ Right click on account name / folder name
2/ Select New Folder/Subfolder
3/ New Folder dialog appears
4/ Account name / folder name appears in the "Create as a subfolder of:" picker
5/ Click on the picker

Actual result
1/ Two entries for account name

Expected result
1/ One entry for account name

Note:
If you click on one of the arrows to expand the subfolders under the account name, even more menu items appear in the main drop down.
Each time you click on the drop down you get more menu items appearing in the list.

I attach some screenshots to demonstrate.
Attachment #673726 - Flags: feedback?(iann_bugzilla) → feedback-

Comment 6

5 years ago
Created attachment 674372 [details]
New Folder Dialog

Comment 7

5 years ago
Created attachment 674373 [details]
Screenshot on first click of dropdown

Comment 8

5 years ago
Created attachment 674374 [details]
Screenshot on clicking arrow to expand into subfolders
(Assignee)

Comment 9

5 years ago
Created attachment 674382 [details] [diff] [review]
patch v2

I can see the problem in that dialog. I forgot some occurrences of 'this.' before MailServices. I wonder why it worked at all other places I tested. Probably those places were already importing mailServices globally.

This should be better.
Attachment #673726 - Attachment is obsolete: true
Attachment #673726 - Flags: feedback?(philip.chee)
Attachment #674382 - Flags: feedback?(iann_bugzilla)
(Assignee)

Updated

5 years ago
No longer blocks: 720356
Summary: Convert mailnews/base/content/folderWidgets.xml to Services.jsm and mailServices.jsm → Convert mailnews/base/content/folderWidgets.xml to mailServices.js

Updated

5 years ago
Attachment #674382 - Flags: feedback?(iann_bugzilla) → feedback+
(Assignee)

Comment 10

5 years ago
Comment on attachment 674382 [details] [diff] [review]
patch v2

Thanks Ian.
Attachment #674382 - Flags: review?(neil)

Updated

5 years ago
Attachment #674382 - Flags: review?(neil) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/d1b29dd7efd3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 19.0
You need to log in before you can comment on or make changes to this bug.