Browser addon can not be read by firefox

RESOLVED DUPLICATE of bug 762648

Status

P2
normal
RESOLVED DUPLICATE of bug 762648
6 years ago
6 years ago

People

(Reporter: dd, Assigned: evold)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.40 Safari/537.11

Steps to reproduce:

Hi guys, I have big troubles with addon development for Firefox Mobile. I had addon for previous Firefox Mobile architecture and now I need to make it NativeUI-compatible. 


Actual results:

The problem is that I can't use it on my device, once installed Firefox lists it in the addon manager, but the addon does not work since:

10-21 23:19:33.483: E/GeckoConsole(3541): [JavaScript Warning: "WARN addons.xpi: Error loading bootstrap.js for test@extension: Error opening input stream (invalid filename?)"]
10-21 23:19:33.483: E/GeckoConsole(3541): [JavaScript Warning: "WARN addons.xpi: Add-on test@extension is missing bootstrap method startup" {file: "resource://gre/modules/XPIProvider.jsm" line: 3708}]

I tried to test it on HTC Sensation with different versions of Firefox Mobile (including Nightly), today I checked it on Samsung 5830i (arm_v6). And the problem is the same. The same problem I'm getting with custom simple addon created using addon sdk. So the reason is not my addon and not any of my devices. Also, I tried to pack addon manually with different zipping program, result is always the same.

This issue is also listed here: https://bugzilla.mozilla.org/show_bug.cgi?id=762648
and seems it's ignored by firefox developers since they are not interested to resolve this issue, just are closing the issue as worksforme or telling about invalid issue description. That's not serious
(Reporter)

Updated

6 years ago
Severity: normal → critical
Component: Add-on Manager → Plugins
Severity: critical → normal
Component: Plugins → General
OS: Windows 7 → Android
Hardware: x86_64 → ARM

Comment 1

6 years ago
You're installing an addon with unpack=false from the SD card, aren't you?

If so, this might be related to bug 730040.
(Reporter)

Comment 2

6 years ago
OMFG, I broke my phone, my keyboard, adb and google trying to find any solution. It really works with em:unpack set to true. Why didn't you put it somewhere in the documentation? :)
This should be documented somewhere off of https://developer.mozilla.org/en-US/docs/Extensions/Mobile

mfinkle do we have any plans on making unpacked extensions from the sdcard?
Flags: needinfo?(mark.finkle)
...making unpacked extensions work from the sdcard?
I don't think this is important, especially since we don't support profiles on the sd card. Do we support em:unpack=false at all? I mean does it work in the profile?

We should update the documentation, as Kevin suggested.
Flags: needinfo?(mark.finkle)
Wont-fix and doc-update?

Comment 7

6 years ago
Hi, I have similar problem in my log, after reading different post I had solution for me
Maybe the problem is the same...
When We do xfc --force--mobile xpi, in the bootstrap.js file, before the method:
function shutdown(data, reasonCode) {
there is a ';'. 
I deleted the ';' and now my extension work also installing it manually.

bye
Status: UNCONFIRMED → NEW
Ever confirmed: true
Sounds like a problem with the SDK then.
Component: General → General
Product: Firefox for Android → Add-on SDK
Version: Firefox 19 → unspecified
Erik, can you take a look at this? Apparently it's a problem with extensions stored on an SD card.
Assignee: nobody → evold
Priority: -- → P2

Comment 10

6 years ago
(In reply to Angelo from comment #7)
> Hi, I have similar problem in my log, after reading different post I had
> solution for me
> Maybe the problem is the same...
> When We do xfc --force--mobile xpi, in the bootstrap.js file, before the
> method:
> function shutdown(data, reasonCode) {
> there is a ';'. 
> I deleted the ';' and now my extension work also installing it manually.
> 
> bye

Sorry this was a fake solution... is not working, 
The only way that i found to run xpi without connection to pc is by a script in android that emulate cfx run.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 762648
You need to log in before you can comment on or make changes to this bug.