Closed Bug 804084 Opened 7 years ago Closed 5 years ago

Beatport music player does not work anymore

Categories

(Web Compatibility :: Desktop, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mcsmurf, Unassigned)

References

()

Details

(Keywords: regression)

To reproduce:
1. Fetch a current trunk build
2. Go to http://www.beatport.com
3. Try to hit the Play button on any song on the right side of the page (below Top 10); the Play button (image) will appear as soon as you hover over any song.

Results:
The Play button does not change it's color when you hover over it and also clicking on the Play button does not do anything.

Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9cfb80a82883&tochange=9d285bedbc1f (broke between 2012-09-22 and 2012-09-23 nightly)
As http://hg.mozilla.org/mozilla-central/rev/b461a7cd250e still works fine, I suspect this is another fallout from Bug 726615?
Setting dom.w3c_touch_events.enabled to false fixes the issue.
Assignee: nobody → english-us
Blocks: 726615
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Product: Core → Tech Evangelism
Version: Trunk → unspecified
I've contacted Beatport Support (support at beatport.com). Let's see if this gets us anywhere.
Beatport Support mailed me back, they forwarded my mail to the website developers.
No longer blocks: 726615
Depends on: win-touch-issues
Working for me.
Thanks Frank.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 5 years ago
Component: English US → Desktop
Resolution: --- → FIXED
No longer depends on: win-touch-issues
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.