Closed Bug 804116 Opened 10 years ago Closed 10 years ago

Firefox does not implement XML 1.0 5th edition extensions to XML Names

Categories

(Core :: XML, defect)

17 Branch
x86_64
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 501837

People

(Reporter: rakesh.makluri, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.40 Safari/537.11

Steps to reproduce:

1. Open the attached xml document in Firefox



Actual results:

An error "XML Parsing Error: not well-formed" throwed


Expected results:

According the the W3C XML 1.0 Spec(http://www.w3.org/TR/REC-xml/#NT-NameStartChar), "CJK Compatibility Ideographs" should be allowed as XML names.
Severity: normal → blocker
Summary: FF is not allowing the multi-byte characters("CJK Compatibility Ideographs" in the range 0xF900-0xFAFF) in XML Names with → FF is not allowing the multi-byte characters("CJK Compatibility Ideographs" in the range 0xF900-0xFAFF) in XML Names
Attachment #673828 - Attachment mime type: text/plain → application/xml
Component: Untriaged → XML
Product: Firefox → Core
Henri might have opinions here
The attachment is not XML according to XML 1.0 4th edition and earlier. After XML 1.1 flopped, the W3C changed the definition of 1.0 to fold some changes from XML 1.1 while pretending that the result is still XML 1.0. Of course, such changes are a really bad idea in a format that has Draconian error handling.
Severity: blocker → minor
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Summary: FF is not allowing the multi-byte characters("CJK Compatibility Ideographs" in the range 0xF900-0xFAFF) in XML Names → Firefox does not implement XML 1.0 5th edition extensions to XML Names
Duplicate of bug: 501837
You need to log in before you can comment on or make changes to this bug.