Geolocation times out too early to get a fix

RESOLVED WORKSFORME

Status

()

Core
DOM: Device Interfaces
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: gerard, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Reporter)

Description

5 years ago
Please refer to bug 803819 for the early story. To summarize, A-GPS seems not working on my Nexus S (maybe lack of data, however I have WiFi enabled), hence the GPS fix is long to acquire.

Both the Maps application or any geolocation request from a website in the Browser application did not waited long enough to get a GPS fix, timing out after less than 30 or 60 seconds. Using the gaia application proposed in bug 804126, I finally get a GPS fix (after waiting several minutes which is expected for a cold start gps fix), and any further attempts to get a fix from Maps or any website in Browser is okay.

Something that might be relevant, too, is that geolocation localized me in a couple of seconds thanks to ip-based geolocation (since WiFi was enabled). Of course it was totally wrong, localizing in Lyon, France while I was 500kms away. But maybe somehow it played a role, letting the system think it was not worth trying harder to get gps fix.
Is this a platform issue?
A-GPS is not enabled by default atm.  We're still working through the product side of that.
(Reporter)

Comment 3

5 years ago
I understand that A-GPS is not enabled, and it explains why the fix takes longer. What I don't understand is why Maps or Browser stops waiting for GPS fix. I'm not sure if it's a bug, but it's obviously a non user friendly behavior.
(Reporter)

Updated

5 years ago
Assignee: nobody → doug.turner
Maps certainly does.  It waits for at least a minute when I use GPS in my apartment.

Updated

5 years ago
Component: Gaia → DOM: Device Interfaces
Product: Boot2Gecko → Core

Comment 5

5 years ago
Alexandre,

http://dl.dropbox.com/u/8727858/mozilla/geolocation/geo.html

Loading that url in the browser while outside, i do see a geolocation fix after about 90 seconds or so.  I did not try on a Nexus S.  I used an Otoro device.
This sounds like it's simply "GPS hardware too slow". I don't think that there's a whole lot we can do about that.
blocking-basecamp: ? → -
There most certainly is, please read comment 2.  Bizdev isn't tracked in bugzilla though.
(Reporter)

Comment 8

5 years ago
(In reply to Jonas Sicking (:sicking) from comment #6)
> This sounds like it's simply "GPS hardware too slow". I don't think that
> there's a whole lot we can do about that.

Okay, GPS slow, it's exactly what I said, but is it normal that it aborts ? I tested on my Android device (HTC Desire Z), and it never gives up.

(In reply to Doug Turner (:dougt) from comment #5)
> Alexandre,
> 
> http://dl.dropbox.com/u/8727858/mozilla/geolocation/geo.html
> 
> Loading that url in the browser while outside, i do see a geolocation fix
> after about 90 seconds or so.  I did not try on a Nexus S.  I used an Otoro
> device.

I'm sorry I did not measured, but my fix took a little longer to get than 90 seconds, maybe 3 mins. Which is not very bad for a cold-start non A-GPS fix.

So, you confirm it's not a bug that if GPS is a little too long to get a fix, we abort ? With the unfriendliness that it brings ?

I agree it's not a blocker.

Comment 9

5 years ago
unassigning things that I am not working on.

Updated

5 years ago
Assignee: doug.turner → nobody
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.