Over-invalidation in SMS conversation view

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR
 (1) Send and receive enough SMS's that a conversation view becomes scrollable
 (2) Enable paint flashing
 (3) Scroll up and down the conversation view

We repaint a lot more than we should: the entire header of the SMS app is always repainted, and sometimes the background behind the messages themselves flashes.  But, oddly enough, sometimes not.
Chris: Could you please grab an invalidation log for this (maybe with MOZ_DUMP_PAINT_LIST=1 too).

Updated

6 years ago
Component: Gaia → Gaia::SMS
[:cjones] In the case of the header is due to the 'fixed' header stuff (we have the same in contacts and calllog). Could you take a screenshot of the 'repainting' of the background? Thanks!
Flags: needinfo?(jones.chris.g)
No longer reproduces.  Mystery fix.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(jones.chris.g)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.