Going to voicemail (T-Mobile) from notification status doesn't open phone app

RESOLVED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia::System
P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: lsblakk, Unassigned)

Tracking

({b2g-testdriver, unagi})

unspecified
B2G C2 (20nov-10dec)
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:+)

Details

When I unlocked my phone this morning I had a notification that there was a voice mail for me.  Clicking that notification dialed my T-Mobile voicemail but didn't either show that I was now on a call or take me to the phone app (which is what I would have expected).  I was able to navigate to the phone app and use the keypad during the call which ended up being to set up the voicemail.

At the end of the call, when I tried to hang up it actually dialed back the number the voicemail came from and then crashed when I tried to hang up _that_ call.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?

Comment 1

6 years ago
I tapped on the voicemail notification, and it connected automatically without the phone app opening. When I opened the phone app, I wasn't able to use the dialer to enter a pin to set up voicemail.
We have to either fix this or cut the feature.
blocking-basecamp: ? → +

Updated

6 years ago
Priority: -- → P1

Updated

6 years ago
Duplicate of this bug: 805066
Assignee: nobody → marshall

Comment 5

6 years ago
Milestoning for C2 (deadline of 12/10), as this meets the criteria of "remaining P1 bugs not already milestoned for C1".
Target Milestone: --- → B2G C2 (20nov-10dec)
It's hard to get a voicemail notification with an Orange simcard, can someone from QA check that this bug has been resolved fixed by bug 804073.
Keywords: qawanted

Updated

6 years ago
Component: Gaia → Gaia::Dialer

Updated

6 years ago
Component: Gaia::Dialer → Gaia::System
FWIW, the voicemail notification just calls the publicly exposed telephony DOM API:
https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/voicemail.js#L68-73

This might be easy to reproduce in any other app by just trying to call mozTelephony.dial("some number")
Assignee: marshall → nobody
That would make it a resolved fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.