crash when onmouseover of <object data="someImage.gif"> fires

VERIFIED WORKSFORME

Status

()

Core
Event Handling
--
critical
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Martin Honnen, Assigned: joki (gone))

Tracking

({crash})

Trunk
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
The following page crashes when mousing over the image included with the object tag
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
                        "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>
object event test
</title>
<script type="text/javascript">
function dumpEvent (evt) {
  if (window.event)
    document.all.output.innerHTML =
      event.type + ' at ' + new Date() + '<br \/>' +
      document.all.output.innerHTML;
  else 
    document.getElementById('output').innerHTML =	
      evt.type + ' at ' + new Date() + '<br \/>' +
      document.getElementById('output').innerHTML;
}
</script>
</head>
<body>
Below is an image included with the object tag:
<br>
<object data="http://www.mozilla.org/images/mozilla-banner.gif"
        type="image/gif"
     onmouseover="dumpEvent(event)"

>
alternative content
</object>
<br>
<hr>
<div id="output"
     style="font-size: 8pt;"
></div>
</body>
</html>
(Reporter)

Comment 1

17 years ago
Created attachment 34212 [details]
bug demo (mouseover the image causes crash)
(Assignee)

Comment 2

17 years ago
I belive this is a dupe of 58429 which was fixed last week.  What build are you 
using?
Severity: normal → critical
Keywords: crash

Comment 3

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Updated

17 years ago
Keywords: nsenterprise

Comment 4

17 years ago
Yes, this bug is fixed in the latest build.  Marking as such.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
Verified on build 2001-06-28 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.