"You don't have any add-ons of this type installed" after today's Firefox 17 beta update

RESOLVED DUPLICATE of bug 671894

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 671894
5 years ago
5 years ago

People

(Reporter: mgol, Unassigned)

Tracking

17 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121017073013

Steps to reproduce:

I updated Firefox 17 beta today.


Actual results:

All my add-ons disappeared from the Tools -> Add-ons menu (or about:addons), giving me a message:
"You don't have any add-ons of this type installed"
Besides this page's malfunction, all my add-ons keep working correctly.


Expected results:

Add-ons should be visible at the about:addons URL.
(Reporter)

Updated

5 years ago
Hardware: x86 → x86_64
Please start Firefox in the Firefox safemode (help/restart with addons disabled) and try to open the addon page again.
It doesn't help, the only added thing is the bar informing me that all add-ons have been temporarily disabled; the list is still empty.
Now it suddenly started working, weird. But Firefox started in a state with all add-ons disabled and with all of them prompting me in separate tabs if I allow to install them. After restarting it all is OK now...
If your extensions.log file contains a NS_Storage_error_busy message, then this is a duplicate of bug 671894 (fixed in F18).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671894
It doesn't contain that line. So I guess I'm reopening.

$ cat extensions.log 
2012-10-23 21:09:17 ERROR addons.xpi-utils: Failed to open database (1st attempt): [Exception... "Component returned failure code: 0x80630001 (NS_ERROR_STORAGE_BUSY) [mozIStorageService.openUnsharedDatabase]"  nsresult: "0x80630001 (NS_ERROR_STORAGE_BUSY)"  location: "JS frame :: resource:///modules/XPIProvider.jsm -> resource://gre/modules/XPIProviderUtils.js :: XPIDB_openDatabaseFile :: line 478"  data: no] at resource:///modules/XPIProvider.jsm -> resource://gre/modules/XPIProviderUtils.js:478
2012-10-23 21:09:17 ERROR addons.xpi-utils: Error processing file changes: TypeError: this.installLocations is null at resource:///modules/XPIProvider.jsm:1822
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(In reply to Michał Z. Gołębiowski from comment #5)
> It doesn't contain that line. So I guess I'm reopening.
> 
> $ cat extensions.log 
> (NS_ERROR_STORAGE_BUSY) [mozIStorageService.openUnsharedDatabase]" 
> nsresult: "0x80630001 (NS_ERROR_STORAGE_BUSY)"  location: "JS frame ::

Actually it does. 

Not quite the way I've spelled it, but still the same.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671894
Ah, sorry, I must have been blind today.
You need to log in before you can comment on or make changes to this bug.