Closed Bug 804851 Opened 7 years ago Closed 7 years ago

[Desktop Build] Contacts app never dismisses "Import from SIM" screen when trying to import from (non-existent) SIM card

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set

Tracking

(firefox17 unaffected, firefox18 fixed, firefox19 fixed)

VERIFIED FIXED
Tracking Status
firefox17 --- unaffected
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: cpeterson, Assigned: cpeterson)

Details

(Whiteboard: b2g-desktop-builds)

Attachments

(1 file)

STR:
1. Open Contacts app
2. Tap gear icon
3. Import from SIM

RESULT:
The Contacts app never dismisses the "Importing from SIM..." screen. The error console reports:

JS Component Loader: ERROR resource://gre/modules/ContactService.jsm:25
                     TypeError: Cc['@mozilla.org/telephony/system-worker-manager;1'] is undefined


The problem is that the B2G Desktop build does not support telephony.
Add telephony mock object to avoid Contacts app errors on B2G Desktop.
Assignee: nobody → cpeterson
Status: NEW → ASSIGNED
Attachment #674463 - Flags: review?(anygregor)
Comment on attachment 674463 [details] [diff] [review]
mock-desktop-telephony.patch

Thx!
Attachment #674463 - Flags: review?(anygregor) → review+
Comment on attachment 674463 [details] [diff] [review]
mock-desktop-telephony.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Not a regression.
User impact if declined: B2G phone users will not be affected, but it is annoying for testers using the B2G Desktop Build.
Testing completed (on m-c, etc.): B2G + mozilla-central
Risk to taking this patch (and alternatives if risky): Handles JS error case that only affects B2G Desktop Build.
String or UUID changes made by this patch: N/A
Attachment #674463 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/eb06e830422d
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Attachment #674463 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Device: Unagi
Build: 20130103070201
Desktop SIM contacts to Device works properly on this build and device.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.