[Browser] Large white overlay obscuring content on Banco do Brasil (Brazilian bank) website in B2G browser

RESOLVED INVALID

Status

Firefox OS
General
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: gkw, Assigned: jet)

Tracking

({b2g-testdriver, unagi})

unspecified
ARM
Gonk (Firefox OS)
b2g-testdriver, unagi
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 674498 [details]
screenshot

1. Go to http://www.bb.com.br/ - it is a Brazilian bank website.
2. Scroll to bottom. There is a large white overlay that obstructs the content.

In particular, it obscures the "Find us on Facebook" section, the "Destaques de Esporte e Cultura" sections, etc.

Does not seem to happen on Desktop, and on the Firefox Mobile on Android, I can see the "Find us on Facebook" section too.

Thanks to Felipe for suggesting this bank website URL.

Nominating blocking-basecamp as this may be an often-used Brazilian site.


===

My Git commit info currently shows:

2012-10-23 10:44:59
0b8ec9b8c16429dc35453dbb7b9342fab3dd... (I see ellipsis at the end) 

Also, seeing my comments in https://b2gtestdrivers.allizom.org/comments_table - my build ID currently is:

20121023173158
I think this might be the flash plugin which of course doesn't load since there is no flash on the device...
Component: Gaia → Gaia::Browser
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
Summary: Large white overlay obscuring content on Brazilian bank website in B2G browser → [Browser]Large white overlay obscuring content on Brazilian bank website in B2G browser
(Reporter)

Comment 2

5 years ago
I took a quick glance and the only thing I saw that was Flash on Desktop was "BB no Youtube" and even that seems many pixels away from "Find us on Facebook".
Component: Gaia::Browser → General
If it were flash-related, I'd say see bug 786890.  But I won't.
Jet, is this a layout issue?

Lawrence, is this a top site in Brazil?
Assignee: nobody → bugs
blocking-basecamp: ? → +
(Reporter)

Comment 5

5 years ago
According to Wikipedia (which may or may not be accurate at all),

Banco do Brasil is "the largest Brazilian and Latin American bank by assets, and the third by market value."

https://en.wikipedia.org/wiki/Banco_do_Brasil
Summary: [Browser]Large white overlay obscuring content on Brazilian bank website in B2G browser → [Browser] Large white overlay obscuring content on Brazilian bank website in B2G browser
(Reporter)

Updated

5 years ago
Summary: [Browser] Large white overlay obscuring content on Brazilian bank website in B2G browser → [Browser] Large white overlay obscuring content on Banco do Brasil (Brazilian bank) website in B2G browser
(In reply to Andrew Overholt [:overholt] from comment #4)
> Lawrence, is this a top site in Brazil?

Yes. Alexa ranks bb.com.br the 43rd most visited site in Brazil and it is ranked 1,390 globally.

There is a mobile version of this site that is served to Firefox for Android. I don't think it's worth evangelism to fix the desktop site for B2G. We should instead work on getting mobile content served to this platform.
Blocks: 806358
(Reporter)

Comment 7

5 years ago
> There is a mobile version of this site that is served to Firefox for
> Android. I don't think it's worth evangelism to fix the desktop site for
> B2G. We should instead work on getting mobile content served to this
> platform.

Firefox for Android 2012-10-30 nightly seems to work fine with the mobile version of the site being served.
I can still reproduce on 2012-11-14.  Jet, can you find someone to take a look?
Flags: needinfo?(bugs)
Renoming. I would like to understand why this bug manifests on the site but I think with a UA override for this site to force the mobile version this no longer blocks.
blocking-basecamp: + → ?
(Assignee)

Comment 10

5 years ago
If we can get past this by forcing the Mobile site, then by all means let's do so.
Flags: needinfo?(bugs)
blocking-basecamp: ? → -
Assuming the mobile site is functional on B2G with a UA override, we will force the mobile site for bb.com.br in bug 819210.
(Assignee)

Updated

5 years ago
Depends on: 819210
Resolving invalid because it's about the desktop site, and since bug 826711 is fixed we're getting the mobile site :)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.