Closed Bug 804887 Opened 12 years ago Closed 12 years ago

[Camera] [Unagi] Image doesn't save to Wallpaper when taken from camera

Categories

(Core :: DOM: Device Interfaces, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: tchung, Unassigned)

Details

Attachments

(1 file)

Attached file logcat
When changing wallpaper, choose the camera option, and take a picture.  The image saves to gallery, but does not get immediately applied as the wallpaper option.

P2. Flagging for blocking-basecamp triage as broken expected functionality, but can be worked around.

Logcat attached.

Repro:
1) install 10-23-2012 unagi daily build
* BuildID=20121023173158
2) settings > Display > Wallpaper (tap the image)
3) choose the Camera activity
4) take a picture with the camera
5) Verify the image saves, but doesn't update the wallpaper option.   (this was the whole point of this feature!)
** Workaround is to go to gallery, and choose the image you just took, and apply to wallpaper that way.

Expected:
- apply the camera image you took directly to the wallpaper feature

Actual:
- camera image doesnt apply to the wallpaper feature
:tchung

Did you test with https://bugzilla.mozilla.org/show_bug.cgi?id=796289 applied to your build? it was merged into master a few hours ago and this functionality was not implemented without it
(In reply to Dale Harvey (:dale) from comment #1)
> :tchung
> 
> Did you test with https://bugzilla.mozilla.org/show_bug.cgi?id=796289
> applied to your build? it was merged into master a few hours ago and this
> functionality was not implemented without it

The probably not.  the build i have was generated 13 hours ago.   i can retest this on tomorrow's daily build, which should pick up the gaia merge in 7 hours.
dale, if that bug is the fix for this work, please be sure to set that bug to resolved fixed, and mark this bug fixed by that bug.   Thanks!
This is working now with the latest codes. Let's close it. ;)
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
blocking-basecamp: ? → ---
(In reply to Gene Lian [:gene] from comment #4)
> This is working now with the latest codes. Let's close it. ;)

Gene, this should be marked Resolved:Fixed, since bug 796289 was the fix that affected this regression.  

Resolved:WorksForMe is usually for bugs that don't reproduce anymore, not because of a bugfix.   

Thanks!
Resolution: WORKSFORME → FIXED
verified fix on 10-30-2012 daily unagi build.  selecting a camera picture now applies to the wallpaper.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: