Video controls are not displayed for HTML5 videos at html5rocks.com

RESOLVED WORKSFORME

Status

()

Firefox for Android
Toolbar
P5
normal
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: AdrianT, Unassigned)

Tracking

17 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox17 affected, firefox18 affected, firefox19 affected, fennec+)

Details

(Whiteboard: [html5Video], URL)

(Reporter)

Description

5 years ago
Firefox Mobile 17.0b3
Device: Samsung Galaxy Tab 2 7.0 (Android 4.0.4) / Samsung Galaxy S2 (Android 4.0.3)

Steps to reproduce:
1. Go to http://www.html5rocks.com/en/tutorials/video/basics/
2. Scroll down to the "2. Video Formats" section and try to play the 3 videos

Expected results:
The user can play the videos

Actual results:
Unless the user uses a long-tap -> fullscreen and then starts the playback using the HTML5 video controls he/she will not be able to start the videos

Note:
Issue is not reproducible on the Android Browser
There are certaintly controls defined on the video element, and the vide on it's own displays controls (http://people.mozilla.com/~atrain/mobile/tests/nocontrols.html). This leads me to believe that they are being cut off by a div container for some reason.
Component: Video/Audio → Graphics, Panning and Zooming
Product: Core → Firefox for Android
Version: 17 Branch → Firefox 17

Updated

5 years ago
tracking-fennec: --- → ?
Assignee: nobody → wjohnston
tracking-fennec: ? → 17+
tracking-fennec: 17+ → +
The unified controls in bug 704229 help with this a bit.
Depends on: 704229

Updated

5 years ago
Whiteboard: [html5Video]
I don't have time to look at this right now. We need to make our controls more responsive (a bit hard since the w3c refuses to let us know the size of a particular element in our stylesheets, but desktop's already done some legwork here.

It would also be really nice if they knew the zoom level and could adjust to it as well...
Assignee: wjohnston → nobody
filter on [mass-p5]
Priority: -- → P5
This works for me.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.