Wrong RSS feed showing and none showing after certain number/time

RESOLVED WORKSFORME

Status

MailNews Core
Feed Reader
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: DLD, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121010144125

Steps to reproduce:

I read a large number of RSS feeds using Thunderbird.


Actual results:

When clicking on a feed in the list Thunderbird often displays the wrong feed in the preview window. It then displays the wrong feed. It seems as if it is trying to display the last feed clicked on rather than the one I've currently clicked on. It is often very difficult to get it to display the actual feed I want.

But after a certain time, or number of feeds, it won't even display the list of feeds. So I can be browsing one folder of feeds but when I switch to the next folder the list is blank. From then on all folders of feeds are blank. If I close Thunderbird and start it again, I then get the feeds displayed correctly in the folder. 

I'm not sure if this is related to the number of feeds I have read or the time I have been reading them. In most cases this occurs when I get to a particular folder but if I have not read many feeds when I get to that folder the folder will be displayed correctly.

My NEWS & BLOGS section is split into 12 main sub-folders and 120 further sub-folders. The folder list usually goes blank on sub-folder 42.

I don't know if this issue is related to the number of feeds I have read or a memory issue. My machine has 12GB of unused memory but I don't know if Thunderbird is allocating some sort of array that is being used up.


Expected results:

Thunderbird should display the RSS feed I have clicked on and display the list of RSS feeds in the sub-folder I am currently displaying.
Component: Untriaged → Feed Reader
Product: Thunderbird → MailNews Core

Comment 1

6 years ago
does this happen in Tb17?  are there errors in the error console?
(Reporter)

Comment 2

6 years ago
It seems to be slightly better under Tb17, but I'm still getting loads of problems. I'm now occasionally seeing short versions of the RSS feeds in the preview window rather than the longer ones. That didn't happen before. I have to go to a completely different feed, wait for it to load correctly, and the go back to the first one, before it will load correctly. Even then, sometimes it loads correctly and other times I need to repeat it a number of times before it does.

Mostly TB seems to be trying to display a feed even if I have moved on to another one, or even deleted the first one. It seems as if it is having a problem displaying the feed for some reason, but is still trying even if I have moved to another feed. Often I have to go to a completely different feed and wait for it to be displayed before I can go back to the one I want to read. If I don't, and I go back to the one I want to read, before I have successfully gone to another, then it will just display the wrong feed content against the correct feed description. I'm not sure if I've explained that well enough, but it is like it has a buffer full of data that it is trying to display even though I'm now on a different feed.

I'm pretty sure the issue is related to the performance of the website providing the feed, but I don't really understand how RSS feeds work. The reason I say that is because certain website feeds display almost immediately and other don't.

I am still getting completely blank lists for some websites. I've been trying to work out why and all I can say so far is that it always happens on the same feed website but only if I have read all the feeds from the top of the list. So, if I go straight to the feeds for that website, I will see the complete list. But, if I go down reading all feeds from the top, that websites feeds will be blank. If I then exist TB and go back in, then the feed list will be displayed. Again, it seems like some sort of buffer has been filled, but I really don't know.

The error console is full of errors. Most are like these

Timestamp: 26/11/2012 16:15:36
Warning: Unknown property 'mso-margin-bottom-alt'.  Declaration dropped.
Source File: mailbox:///E:/Thunderbird/Profiles/nzibo95d.default/Mail/Local%20Folders/67737d8e?number=11892981
Line: 0

Timestamp: 26/11/2012 16:14:58
Warning: XUL box for _moz_generated_content_before element contained an inline #text child, forcing all its children to be wrapped in a block.
Source File: chrome://messenger/content/messenger.xul
Line: 0

Timestamp: 26/11/2012 16:21:54
Error: no element found
Source File: http://downloads.bbc.co.uk/podcasts/radio4/did/rss.xml
Line: 1

Timestamp: 26/11/2012 16:21:54
Error: [Exception... "'Component is not available' when calling method: [nsIActivityManager::removeActivity]"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource:///modules/activity/pop3Download.js :: <TOP_LEVEL> :: line 124"  data: no]
Source File: resource:///modules/activity/pop3Download.js
Line: 124

Comment 3

6 years ago
1. prior to Tb17, a feed message (summary mode) was displayed only after all images were loaded.  this is no longer true in Tb17+ and the content will be loaded incrementally, thus seeming 'faster'.

2. 'no element' is a lower level gecko error meaning there is nothing to parse at the publisher end.  a browser would show an empty page.

3. there is not much concrete (like feed url) to be helpful.  if you are loading the web page and the feed item page url points to an mp3, this will possibly take a long time and may be transparent depending on how mime types are handled in your setup.
(Reporter)

Comment 4

6 years ago
I was getting a blank list when I got to a particular feed/folder. Exiting TB and starting it again would then display the list. Today when I got to that feed/folder TB just exited and I got this error in the error console

Timestamp: 27/11/2012 16:43:25
Error: ReferenceError: google_adnum is not defined
Source File: http://www.pcpro.co.uk/reviews/monitors/378352/eizo-flexscan-ev2316w
Line: 863

When I went back into TB the list displayed fine.

In 2) above you say that there is nothing to parse. Does this that TB thinks it has a page display but doesn't find one, or that it is just checking the feed and finding nothing there to display? The error console is full of the 'no element' messages.

Comment 5

5 years ago
to followup: none of the errors above are related to Tb feeds code.  a 'no element found' means either a network or publisher server side error. the 'ReferenceError' above is an error in the publishers webpage script.

if you have a particular feed set to load web page (rather than summary) and the page contains bad links or is slow loading or such, there is nothing a client like Tb can do about that.

and the feed at http://downloads.bbc.co.uk/podcasts/radio4/did/rss.xml works fine for me, both as web page and summary.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

5 years ago
Just to add a comment. I'm now seeing the correct feed following recent TB updates. I still often see a short version instead of the fully formatted version. This always happens if a feed is slow to load and I go to another one. I have to go to another feed, wait for it to load and then I can go back to the original feed. It can take many goes before I see the full feed.

But the bug I'm still getting constantly is TB crashing when reading a feed. I get no error message or anything. TB just exits. I still haven't managed to work out when it is going to occur but it seems to be after a certain number of feeds being read. 

My feeds are structured into folders and it nearly always occurs on the same folder. But if I've read a smaller number of feeds I can go into that folder without any issues. When I go back into TB I can go into that folder and read the new feeds. But again, after a certain number it will crash again. 

It seems like it is some buffer getting full or something. I get no errors in the error log, just the usual stuff.

The most frustrating thing about it is that when I go back into TB it no longer highlights the new feeds so I have to start reading from the top again.

If you could fix that it would be so great.

Comment 7

5 years ago
short version (summary) or web page load choice is up to you to set per feed.

if the problem can't be reproduced, it can't be fixed.

export your feeds and attach the opml file.
(Reporter)

Comment 8

5 years ago
I appreciate that you can't fix it if you can't reproduce it. That's why I've given as much information as I can. What is an opml file and how do I send it to you? I'm happy to do whatever is required if you tell me how. Is there a debug option that I can turn on that might help?

I've set the option for web page load but that is not what I'm getting. As I explained I only get the full web page load when the website responds quickly. I am often seeing an unformatted web page. I'm not saying that is the short version, but it is not the fully formatted web page load. It appears to be the full web page without any formatting. I get that with some websites in Firefox too. Yahoo is a particular example. If I log into yahoo webmail and then log out, the screen I get seems to have the text but with no formatting. It looks like a CSS file has not loaded or something, but then I probably talking rubbish since I don't really know much about CSS!!!!

Comment 9

5 years ago
DLD: to figure out your crash we need the crash id. (See Help | Troubleshooting | about:crashes

Re the summary briefly showing, i think that's common with slow responses/connection. Then when it gets the full page that's shown. 

IIRC there was a bug where loading full page failed for any load problems on the page (e.g. missing pictures), but that should be fixed in nightly builds.

Comment 10

5 years ago
(In reply to DLD from comment #8)
>  What is an opml file and how do I send it to you?

if you right click on a feed folder and select Subscribe, you will get a dialog listing your folders and subscriptions.  select the top (account) folder and click Export.  a file will be created.  if you feel comfortable attaching it here, click on the Add an Attachment link; otherwise you may email it to me.

but, as magnus said, a crash id would be good.  it may be unrelated to feeds per se, but a mishandling in more generic code.

(In reply to Magnus Melin from comment #9)
> IIRC there was a bug where loading full page failed for any load problems on
> the page (e.g. missing pictures), but that should be fixed in nightly builds.

yes, that's been fixed and is in Tb17.
(Reporter)

Comment 11

5 years ago
Created attachment 766101 [details]
This is the opml file you requested

Sorry it has taken me so long to reply with this file. Thunderbird still closes all the time whilst I'm reading feeds. It usually happens when I get to the PC Pro thread but it seems to depend on the number of threads.

I currently have 179084 threads in the News & Blogs folders and I don't know if that is related to the issue. I don't delete any because I search them when I want to find something and I frequently go back and re-read them.

I don't know how to find a crash id. Thunderbird doesn't crash as such. With Firefox I frequently get crashes and it sends crash info to Mozilla. With Thunderbird the screen just disappears. I then have to start the program again. Occasionally when I restart the program I get a message saying it is already running but most of the time it just starts again. If it tells me it is already running then I just have to wait a few minutes and it will start again ok.

I hope this helps you figure out what is happening.
You need to log in before you can comment on or make changes to this bug.