If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Dismissing alerts causes error & alert is not dismissed (iCal server)

VERIFIED INCOMPLETE

Status

Calendar
Alarms
VERIFIED INCOMPLETE
5 years ago
4 years ago

People

(Reporter: noc-admin, Unassigned)

Tracking

Lightning 2.6.4

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

1. Create an event on a network calendar with an alarm
2. Wait for alarm to raise the alert box
3. Attempt to dismiss the alert

We have a Lion Server with the Calendar Server providing the calendars.
In the "Edit Calendar" dialog, the Location URL is:
https://HOSTNAME/calendars/__uids__/UUID-OF-CALENDAR/calendar
"read only" is not checked, "show reminders" is checked, "cache" is not checked

Events appear and can be added to the calendar, but when alerts appear, it breaks.

For recurring events, it's the same situation, but you cannot edit recurring events for which alarms have already been triggered. I can't even remove the event from the calendar, I must use the web interface of the iCal server instead.

I also have a phone and OSX laptop that subscribe to that calendar. It's possible that they're setting something for that event when their alarms trigger that is causing lightning to be unable to dismiss alarms.


Actual results:

A dialog box appears with the title: "An error has occurred"
With text: "An error occured when writing to the calendar CALENDARNAME!"

Clicking details:
Status Code: 403, The user lacks the required permission to perform the request.

<?xml version='1.0' encoding='UTF-8'?>
<error xmlns='DAV:'>
  <valid-calendar-data xmlns='urn:ietf:params:xml:ns:caldav'/>
  <error-description xmlns='http://twistedmatrix.com/xml_namespace/dav/'><![CDATA[Invalid calendar data: Calendar data had unfixable problems:
  [VALARM] Too many properties present: ATTACH]]></error-description>
</error>


Expected results:

Alarm should be dismissed and no longer present the specific alarm for that event.
Could you attach an example event where this is happening? We don't use the ATTACH property in VALARM components, so I am wondering if this is really a Lightning issue. Please reopen if you are still having this issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

4 years ago
Updated version to latest (still occurring). Adding notes for Philipp:

I think it has something to do with my computer and or iPhone. When I get the event alert/reminder/alarm, that's when the event stops saving. If I create an event without an alarm, there is no problem.

So it looks like iCal on my mac or phone is adding that Basso attachment and Lightning is freaking out.

When you click "Dismiss" in Lightning, it says: "An error occurred when writing to the calendar CALENDAR NAME"

To dismiss the alert, you can simply edit the event and remove the reminder, but I'd love for the Dismiss button to simply overwrite the event and acknowledge the alert.

Thanks

<pre>
BEGIN:VCALENDAR
CALSCALE:GREGORIAN
VERSION:2.0
X-WR-CALNAME:Puppy Test
METHOD:PUBLISH
PRODID:-//Apple Inc.//Mac OS X 10.9.2//EN
BEGIN:VTIMEZONE
TZID:America/Phoenix
BEGIN:DAYLIGHT
TZOFFSETFROM:-0700
DTSTART:19420209T020000
TZNAME:MDT
TZOFFSETTO:-0600
RDATE:19420209T020000
RDATE:19440401T000100
RDATE:19670430T020000
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:-0600
DTSTART:19440101T000100
TZNAME:MST
TZOFFSETTO:-0700
RDATE:19440101T000100
RDATE:19441001T000100
RDATE:19671029T020000
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20140402T161925Z
UID:5c36a7b8-80ab-4b29-9e7d-546b526fa192
DTEND;TZID=America/Phoenix:20140402T102500
TRANSP:OPAQUE
SUMMARY:Puppy Test
LAST-MODIFIED:20140402T161942Z
DTSTAMP:20140402T162500Z
DTSTART;TZID=America/Phoenix:20140402T092500
SEQUENCE:0
BEGIN:VALARM
X-WR-ALARMUID:D9B4C001-402F-4EBB-B3A7-0E27C8C755F9
UID:D9B4C001-402F-4EBB-B3A7-0E27C8C755F9
TRIGGER:-PT30M
ATTACH;VALUE=URI:Basso
ACTION:AUDIO
X-APPLE-DEFAULT-ALARM:TRUE
ACKNOWLEDGED:20140402T155501Z
END:VALARM
BEGIN:VALARM
X-WR-ALARMUID:43E1491B-523C-42F0-8D73-CF1AD58350E9
UID:43E1491B-523C-42F0-8D73-CF1AD58350E9
DESCRIPTION:Default Mozilla Description
ACKNOWLEDGED:20140402T155501Z
TRIGGER:PT0S
ACTION:DISPLAY
END:VALARM
END:VEVENT
END:VCALENDAR
</pre>
Status: RESOLVED → VERIFIED
Version: Lightning 1.8 → Lightning 2.6.4
> Status Code: 403, The user lacks the required permission to perform the
> request.
> 
> <?xml version='1.0' encoding='UTF-8'?>
> <error xmlns='DAV:'>
>   <valid-calendar-data xmlns='urn:ietf:params:xml:ns:caldav'/>
>   <error-description
> xmlns='http://twistedmatrix.com/xml_namespace/dav/'><![CDATA[Invalid
> calendar data: Calendar data had unfixable problems:
>   [VALARM] Too many properties present: ATTACH]]></error-description>
> </error>

This is a server error message, so for some reason the server is rejecting it. Maybe the server just needs to be upgraded? It may also get better when I fix bug 702206.
(Reporter)

Comment 4

4 years ago
Server is getting regular updates and my iPhone/iCal have no problem marking events as acknowledged. I'm lost on this one.
I'm also not sure why this is happening. I'd suggest testing with the patch in the bug I mentioned, or waiting until it is fixed and trying a nightly build.
You need to log in before you can comment on or make changes to this bug.