Social API keyboard-accessible menuitem is blank

RESOLVED FIXED in Firefox 17

Status

()

Firefox
SocialAPI
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: jaws, Assigned: jaws)

Tracking

Trunk
Firefox 19
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox17 fixed, firefox18 fixed, firefox19 fixed)

Details

(Whiteboard: [Fx17][qa-])

Attachments

(1 attachment, 1 obsolete attachment)

Created attachment 674841 [details] [diff] [review]
Patch

Bug 801040 tweaked the keyboard-accessible menu code, and removed the command. The command attribute did server a purpose though, as it set the label on the menuitem.
Attachment #674841 - Flags: review?(felipc)
Attachment #674841 - Flags: review?(felipc)
Created attachment 674843 [details] [diff] [review]
Patch v1.1
Attachment #674841 - Attachment is obsolete: true
Attachment #674843 - Flags: review?(felipc)
Attachment #674843 - Flags: review?(felipc) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/5bbfcd1d5296
Comment on attachment 674843 [details] [diff] [review]
Patch v1.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): needed to fix a regression by bug 801040 (for social api)
User impact if declined: blank menuitem in tools menu
Testing completed (on m-c, etc.): locally and landed on m-c
Risk to taking this patch (and alternatives if risky): none expected
String or UUID changes made by this patch: none
Attachment #674843 - Flags: approval-mozilla-beta?
Attachment #674843 - Flags: approval-mozilla-aurora?
Backed out in https://hg.mozilla.org/integration/mozilla-inbound/rev/5bbfcd1d5296 - Impact when landed: 10 browser-chrome failures.
Oh, and my very favoritest sort of bustage: for historical reasons, Talos treats any run which has the string ERROR in allcaps in the log as a failure, and in Mac Talos other and dirtypaint you were triggering a whole lot of "Exception... "'ReferenceError: separator is not defined' when calling method: [nsIRunnable::run]"  nsresult: "0x8057001c (NS_ERROR_XPC_JS_THREW_JS_OBJECT)"
Relanded with the fixed JS,
https://hg.mozilla.org/integration/mozilla-inbound/rev/6a3dbca1ca7d
https://hg.mozilla.org/mozilla-central/rev/6a3dbca1ca7d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 19
Comment on attachment 674843 [details] [diff] [review]
Patch v1.1

Approving for uplift (even though untracked) since it's needed for the Social API launch in 17.
Attachment #674843 - Flags: approval-mozilla-beta?
Attachment #674843 - Flags: approval-mozilla-beta+
Attachment #674843 - Flags: approval-mozilla-aurora?
Attachment #674843 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/3e8354331660
https://hg.mozilla.org/releases/mozilla-beta/rev/d928e9d045b0
status-firefox17: --- → fixed
status-firefox18: --- → fixed
status-firefox19: --- → fixed
Does this fix need any QA?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #10)
> Does this fix need any QA?

We should be all set here.
Whiteboard: [Fx17] → [Fx17][qa-]
You need to log in before you can comment on or make changes to this bug.